Results 1 to 2 of 2

Thread: What's wrong with my RowExpander plugin? (Take a look at the screen shot!)

  1. #1
    Sencha User
    Join Date
    May 2013
    Posts
    2
    Vote Rating
    0
      0  

    Default What's wrong with my RowExpander plugin? (Take a look at the screen shot!)

    I'm not so familiar with ExtJS 4.x and Architect2. My target is to add Ext.ux.RowExpander plugin into a simple grid in Architect2. I overrode the grid and add the following code in the code view of Architect2:

    PHP Code:
    initComponent: function() {        
          var 
    me this;

          
    Ext.applyIf(me, { 
              
    plugins
                 [{   
    ptype'rowexpander',
                      
    rowBodyTpl: ['<p>Testing</p>'],
                      
    selectRowOnExpand true                
                 
    }]
             });
          
    this.callParent(arguments);    } 
    After the code run, I got such a screen(look at the following pic)


    bug pic.jpg

    What's wrong with it?
    Can anyone help?

    Attached Images Attached Images

  2. #2
    Sencha User existdissolve's Avatar
    Join Date
    Jan 2010
    Location
    Kansas
    Posts
    522
    Vote Rating
    89
      0  

    Default

    Try removing the plugin definition from initComponent()

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •