Results 1 to 4 of 4

Thread: Problem with Row Expander Plugin

  1. #1
    Sencha User
    Join Date
    Jun 2013
    Posts
    72
    Vote Rating
    0
      0  

    Default Problem with Row Expander Plugin

    Running into some issue with the grid row expander plugin, using ext js 3.3. everytime I try to expand the row, it throws this error

    Uncaught TypeError: Cannot set property 'innerHTML' of undefined

    which emanates from the plugin code beforeExpand method (colored red).

    Code:
    beforeExpand : function(record, body, rowIndex){         if(this.fireEvent('beforeexpand', this, record, body, rowIndex) !== false){ 
                if(this.tpl && this.lazyRender){ 
                    body.innerHTML = this.getBodyContent(record, rowIndex); 
    Uncaught TypeError: Cannot set property 'innerHTML' of undefined
    
    
    
                } 
                return true; 
            }else{ 
                return false; 
            } 
        }, 

  2. #2
    Sencha User
    Join Date
    Jun 2013
    Posts
    72
    Vote Rating
    0
      0  

    Default

    can anyone help with this ?

  3. #3
    Sencha User
    Join Date
    Jun 2013
    Posts
    72
    Vote Rating
    0
      0  

    Default

    Just wondering if am the only one on this page, no response still

  4. #4
    Sencha User
    Join Date
    Sep 2015
    Posts
    2
    Vote Rating
    0
      0  

    Default Help

    I know this is very old post... Hoping you were able to find the cause of this issue...
    I have came across same issue, could you please help?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •