Results 1 to 3 of 3

Thread: Chart - incorret legend markers color in a multi-serie bar/line chart

    Success! Looks like we've fixed this one. According to our records the fix was applied for EXTJS-10980 in 4.2.2.1144.
  1. #1
    Sencha User
    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    76

    Default Chart - incorret legend markers color in a multi-serie bar/line chart

    REQUIRED INFORMATION

    Ext version tested:

    • Ext 4.2.1
    Browser versions tested against:
    • Firefox 23
    • Chrome
    Description:
    • If you create a chart with line and bar series, legend markers show incorret colors
    Test Case

    Code:
    var store = Ext.create('Ext.data.JsonStore', {
        fields: ['name', 'data', 'data2'],
        data: [
            { 'name': 'metric one',   'data':10, 'data2':5 },
            { 'name': 'metric two',   'data': 7,'data2': 8 }
        ]
    });
    
    
    Ext.create('Ext.chart.Chart', {
        renderTo: Ext.getBody(),
        width: 500,
        height: 300,
        animate: true,
        store: store,
        legend : true,
        axes: [
            {
                type: 'Numeric',
                position: 'left',
                fields: ['data', 'data2'],
                label: {
                    renderer: Ext.util.Format.numberRenderer('0,0')
                },
                title: 'Sample Values',
                grid: true,
                minimum: 0
            },
            {
                type: 'Category',
                position: 'bottom',
                fields: ['name'],
                title: 'Sample Metrics'
            }
        ],
        series: [
            {
                type: 'line',
                axis: 'left',
                xField: 'name',
                yField: 'data2'
            },{
                type: 'column',
                axis: 'left',
                xField: 'name',
                yField: 'data'
            }
        ]
    });

    INFORMATION

    Screenshot :
    Possible fix:
    • not provided
    Operating System:
    • Win 7

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

  3. #3
    Sencha User
    Join Date
    Mar 2012
    Posts
    50

    Default

    The issue was fixed and it should be part of the next 4.2.x release.
    Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •