Results 1 to 8 of 8

Thread: [2.3.0] Button Image shifted from 0.5px in Chrome

    You found a bug! We've classified it as EXTGWT-3341 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha User
    Join Date
    May 2009
    Posts
    18
    Vote Rating
    0
      0  

    Default [2.3.0] Button Image shifted from 0.5px in Chrome

    Hi


    Button image in ToolBar are shifted (right) from 0.5 pixel only in Google Chrome (and not in all toolbar...!!!)


    Here is a snipet of the generated html for the button (look at the "left" attribute value) :


    Code:
    <button class="x-btn-text" type="button" style="position: relative; width: 16px;" tabindex="0" aria-describedby="x-auto-30" aria-disabled="true">
    &nbsp;
    <img onload="this.__gwtLastUnhandledEvent=&quot;load&quot;;" src="http://10.151.0.201:8080/SIAD/siad/clear.cache.gif" 
    style="width: 16px; height: 16px; 
    background-image: url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAAC7ElEQVR42nWSa0iTYRTHV0HRlyI/9DWIIIg+lRVthhmo1Zx+KDVTiyIMhFgXKDDxLnmZruZmXlY4yEs285K3FEPBbW7qnLo03XRuOudq6qjpXp3bvz2vl7LwwB8ezvn/znue57wMxj/BzmWeDM1nFYTxWUYOj7VCRM4kR2qMnSI8+cRer0kcJbq8LFGnu5WWOujsclpKSy0k/eluUiMe4t0OV4fvCc33k6W13HcOz7dDbn2HDnOhV6INFdK5YVsbUpvjnMRLmK0GoS9Z/OSmO84BWwNqDM/RYExHl0UMzXwjLXImuRpDItQ/6pH46baTMDR8lcc8EikKsPdY36NC/xBLrkXsFGseFxqnsiGfrUKkMMBOWAYnjyUQKR65G4wZKBuPw69V244NVtzLqJ1IQd1kJgTdXDcnn/mKEcZnGtuMJSgZjUXR6E2U67moN6ahfaYAc8vj+Ln6nb4CyZFaoTYKr4ei0TpZDMJ6J/CjVFYpeINBEH69Tk8hnUyAZXls68sO1wIaTS/ommDoGrJ7g6AwV4OwdAOltRpZg/7gD4dA/O0uZpdG/hvf4ZpHpe4xeANsZKj8IZupWm9AxmgxiLwwG7mDgZhZ0m7d1+WhtmCPxwO70wqh5gZy+q6gcUy4eQWWQCB74C7XcZHSfxqdllJQbgeaTVnejSzQDRqmMmB16DBq60ay4hwkWi7yvsSvPyJZRYTwor1zRoxM9QUk9/lCMhaPSv0TeqVra2vel09DqfYeknrOIlXmh/bJEoQX+K+vcfNHSqiPcXaZ3yBPw0aRNhY1+iTYHNOgKCdqdekQaaKRrWSjwyDG0w9Rf34kb+zyOeZzIITHVCbU3aJUlo/oMBWj3VAItaUJg3MdaNUL0TZRBLlJimfSGIp4CUNY0mC3V4cOHt53NDj1jDSyIJgqU2V6+s2fMW0fhWlxBL3TLXiryPBECIIo4iFewmyw22L/qdjjlwKTfCs4OeetIbksFxE5kxypEc/fwG/elnfSf/oGLgAAAABJRU5ErkJggg==); 
    position: absolute; left: 0.5px; top: 0px; background-position: 0px 0px; background-repeat: no-repeat no-repeat;" border="0" role="presentation" class=" x-btn-image">
    </button>
    Anyone is experiencing the same problem ?
    Attached Images Attached Images

  2. #2
    Sencha - Support Team
    Join Date
    Oct 2011
    Posts
    4,088
    Vote Rating
    136
      0  

    Default

    Can you attach a test case reproducing this problem.

  3. #3
    Sencha User
    Join Date
    May 2009
    Posts
    18
    Vote Rating
    0
      0  

    Default

    You can download a sample project here (too big for file attachments) :
    https://dl.dropboxusercontent.com/u/...nChromeBug.zip

    I forget to tell that the bug is only visible in compiled mode so you will have to compile the sample project to reproduce the problem (and check the left attribute using code inspector).

    GXT 2.3.0 (gxt-2.3.0-gwt22.jar)
    GWT 2.5.0
    Google Chrome 29.0.1547.62 m

  4. #4
    Sencha - Support Team
    Join Date
    Oct 2011
    Posts
    4,088
    Vote Rating
    136
      0  

    Default

    OK I am going to move this thread to the GXT bug forums. Thats where you should post any issues that have GXT involved.

  5. #5
    Sencha User
    Join Date
    May 2009
    Posts
    18
    Vote Rating
    0
      0  

    Default

    Hi,

    Any updates about this issue ?

    We still have the problem in 2.3.1.

  6. #6
    Sencha Premium Member feelinforyou's Avatar
    Join Date
    Dec 2012
    Posts
    100
    Vote Rating
    4
      0  

    Default

    It's the same in IE10!

  7. #7
    Sencha - Support Team
    Join Date
    Oct 2011
    Posts
    4,088
    Vote Rating
    136
      0  

    Default

    Looks like this post may have been lost in the mix. I am going to file a bug.

  8. #8
    Ext GWT Premium Member mariusz.pala's Avatar
    Join Date
    Jun 2008
    Location
    Poland
    Posts
    306
    Vote Rating
    2
      0  

    Default

    I have the same issue with GXT 2.3.1. Top margin is set to 0.5px but only in Chrome. And it's random, happens only for some icons. Is there any update on this?

    Thanks,
    Mariusz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •