Results 1 to 7 of 7

Thread: defaultMargins ignored in compiled app

    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-5145 in Architect 3.0.x.
  1. #1

    Default defaultMargins ignored in compiled app

    I upgraded my existing Sencha Architect 2 project to Sencha Architect 3. My project has a couple containers where I defined defaultMargins so the children would have some spacing between them. From within Sencha Architect 3 everything looks right, but when I build (Build Web App) the resulting app ignores whatever values I had defined for defaultMargins, all of those children have 0 margin.

    I don't know if this is a defect in Sencha Architect or Sencha Cmd since Architect is displaying it correctly.

  2. #2
    Sencha User
    Join Date
    Jan 2009
    Location
    Frederick, Maryland
    Posts
    925

    Default

    When you say Architect is displaying it properly; are you talking about in the Architect canvas or a preview of the dev build?
    Jason Minnick
    Sencha Architect Development Team

  3. #3

    Default

    The Architect canvas displays it correctly within the application.

  4. #4

    Default

    It looks like this is a duplicate of:
    http://www.sencha.com/forum/showthre...tead-as-object

    Sorry I didn't dig into the code enough to see what was actually failing. You can ignore this thread.

  5. #5
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    Bug fix is in and it will be fixed in the next patch (after 1337).
    Aaron Conran
    @aconran

  6. #6

    Default

    I'm not sure when the next build will be, so if anyone else is running into this issue, here's a workaround I've been using:

    Code:
    perl -pe "s/defaultMargins:'{(.*?)}'/defaultMargins:{\1}/g" app.js > app2.js; mv app2.js app.js

  7. #7
    Sencha User
    Join Date
    Jan 2009
    Location
    Frederick, Maryland
    Posts
    925

    Default

    Quote Originally Posted by kevin.forbes View Post
    I'm not sure when the next build will be, so if anyone else is running into this issue, here's a workaround I've been using:

    Code:
    perl -pe "s/defaultMargins:'{(.*?)}'/defaultMargins:{\1}/g" app.js > app2.js; mv app2.js app.js
    Should be out Wednesday.
    Jason Minnick
    Sencha Architect Development Team

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •