Results 1 to 4 of 4

Thread: [4.2.x] Sprite.initDraggable throws an error when sprite is added to surface.

    Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Cluj, Romania
    Posts
    722
    Vote Rating
    52
      0  

    Post [4.2.x] Sprite.initDraggable throws an error when sprite is added to surface.

    Ext version tested
    • 4.2.2
    • 4.2.1
    Description
    When trying a sprite with draggable: true, initDraggable throws an error because of missing reference/value of the surface element

    Steps to reproduce the problem

    https://fiddle.sencha.com/#fiddle/1kg

    Code:
        Ext.create('Ext.draw.Component', {
            renderTo: Ext.getBody(),
            width: 200,
            height: 200,
            items: [{
               draggable: true,
               type:'circle',        
               radius:90,        
               x:100,       
               y:100,        
                fill:'blue'
            }]
        });
    Result that occurs
    Last edited by Gary Schlosberg; 18 Nov 2013 at 9:45 AM. Reason: add test fiddle
    Github https://github.com/vadimpopa
    Sencha tips and articles : http://vadimpopa.com
    Twitter: @vadimvpopa

  2. #2
    Sencha Premium User
    Join Date
    Nov 2010
    Location
    Chicago
    Posts
    1,932
    Vote Rating
    548
      0  

    Default

    Looks like a bug, although 'ill' should probably be 'fill'

  3. #3
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Cluj, Romania
    Posts
    722
    Vote Rating
    52
      0  

    Default

    Quote Originally Posted by LesJ View Post
    Looks like a bug, although 'ill' should probably be 'fill'
    thxthat's because of the code formatter + copy&paste
    Github https://github.com/vadimpopa
    Sencha tips and articles : http://vadimpopa.com
    Twitter: @vadimvpopa

  4. #4
    Sencha - Support Team
    Join Date
    Feb 2013
    Location
    California
    Posts
    10,381
    Vote Rating
    263
      0  

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •