Results 1 to 8 of 8

Thread: ItemSelector moves to top of list when moving items around

  1. #1
    Ext JS Premium Member
    Join Date
    Nov 2009
    Posts
    33

    Default Answered: ItemSelector moves to top of list when moving items around

    On the example page of the ItemSelector (http://docs.sencha.com/extjs/4.2.1/e...heme=classic):

    - Move all items to the left;
    - Scroll down
    - Double-click the lowest item in the list, to move it to the right.

    The left list now scrolls up, again. In this case it's not such a problem, but we have bigger lists (50+ items), which makes this rather annoying.

    Is there any easy work-around for this? Maybe even a setting I've overlooked?

  2. This has been corrected in our latest nightly build. You can download this from the support portal

  3. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,409
    Answers
    716

    Default

    Moved thread to Q&A, plugins is for announcements.

    Thanks,
    Scott.

  4. #3
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,409
    Answers
    716

    Default

    This has been corrected in our latest nightly build. You can download this from the support portal

  5. #4
    Ext JS Premium Member
    Join Date
    Nov 2009
    Posts
    33

    Default

    I've just downloaded the latest nightly and tested both the ItemSelector (which is unchanged) and the MultiSelect control (which has some minor changes), but the issue still exists. What file contains the changes?

  6. #5
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,409
    Answers
    716

    Default

    Can you verify the version? See the version at the bottom of this video. Notice the scroll remains at bottom:
    http://screencast.com/t/954jrNFK

  7. #6
    Ext JS Premium Member
    Join Date
    Nov 2009
    Posts
    33

    Default

    My apologies for not being clear. I'm currently unable to test or rollout a new (especially nightly) build of ExtJS, so I hoped the changes were contained in just a few files. That's why I tried to use the new versions of the ItemSelector and MultiSelect controls, but still use the rest of the ExtJS 4.2.2.1144.

    I now get the feeling that's nearly impossible, right?

  8. #7
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,409
    Answers
    716

    Default

    I do not see anything specific to this error in our tracker. It may have been fixed as a result of other fixes.

  9. #8

    Default Were the lines of code specific to this fix narrowed down?

    In same boat, can't upgrade, just need the fix for the ItemSelector moves to top of list issue.

    thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •