Results 1 to 4 of 4

Thread: UI name is not set properly for buttons (large, medium and small)

Hybrid View

Previous Post Previous Post   Next Post Next Post
    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-5142 in Architect 3.1.
  1. #1
    Ext JS Premium Member
    Join Date
    Jan 2012
    Location
    Montreal
    Posts
    50

    Default UI name is not set properly for buttons (large, medium and small)

    Architect version: 3.0.1.1343
    Platform: Windows 8

    When you create a UI for a button from Architect, you need to select if it is for a small, medium or large button type. When you are done, the button does not have any style because the name of the UI is not set properly. If you rename the UI for MyButton, the ui property get set to mybutton, but, in reality, the mixin that get created is called mybuttion-large (if you selected large).

    Also, when you change the UI from "default" to something else which exist, the first time, Architect does not take it; it get set back to "default". If you enter it again a second time, then it takes it properly.

  2. #2
    Sencha User arnebech's Avatar
    Join Date
    Jun 2010
    Posts
    498

    Default

    Thanks for reporting!

    1) Can you be more specific on the UI not applying. If I create a UI for a button, it will look "plain" until the compile finished and then take on the newly created UI (which looks like a normal button until you change the ui variables). Does this not work for you?

    The ExtJS button will look for a ui named "uiName-size" hence when we create a mixin it will be named something like myUi-large, but the UI config will be set to "myUI" and the size will be set to "large".

    2) Can you be more specific about when/where it is not take the UI being set and you have to do it twice? thanks.
    Last edited by arnebech; 8 Jan 2014 at 12:07 PM. Reason: fixed newlines

  3. #3
    Ext JS Premium Member
    Join Date
    Jan 2012
    Location
    Montreal
    Posts
    50

    Default

    Ok, I select a component on the canvas, then I look for the UI property in the config panel. I see that the current UI is Standard. I type my new UI name and press enter. At this point, it replaces what I typed by Standard. If I type the UI name again, then it sticks. Weird...

  4. #4
    Sencha User arnebech's Avatar
    Join Date
    Jun 2010
    Posts
    498

    Default

    Thanks, I was able to reproduce. We have a fix for this that will go out in a future Architect release, but will not make it into the forthcoming minor patch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •