Results 1 to 6 of 6

Thread: Breaking errors after upgrade to 3.0.2.1375

    Wait! Looks like we don't have enough information to add this to bug database. Please follow this template bug format.
  1. #1

    Default Breaking errors after upgrade to 3.0.2.1375

    Hi,

    Today I've been prompted to upgrade architect for a minor update. Right now the About dialog shows the following info:

    version: 3.0.2.1375
    channel: 3.0.1-stable
    platform: 1.3.0.795
    cmd: 4.0.1.45
    framework: Sencha Touch 2.3.x

    But after the upgrade my project opened with so many errors as "There was an error while loading this instance". There are views, stores and models giving this error. And also the ones that give error are shown 2-3 times in the list: one loaded with an error icon, the other ones are unloaded (and when I click the to load them, they don't get loaded).

    This is just a fast analysis but may be it helps:
    the views that give error have Scss Resource
    the stores that give error have mock up data
    also when I open and close views and stores, the error icon disappears but the duplicates are not removed. But the same thing doesn't happen for models.


    So right know my development environment is broken and I need and immediate fix to go on with my work.

    Thanks in advance

    Ipek

  2. #2

    Default

    I'm desperately waiting for a response...

  3. #3
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    Ipek -

    Can you share an archive of your project with us? You can share it privately by sending it to architect.feedback at sencha.com and include a reference to this thread.
    Aaron Conran
    @aconran

  4. #4

    Default

    Thanks for your reply Aaron.

    Something magical happened In order to send our project I've copied the project folder to some place else. I opened the copied project in order to clear our super confidential proprietary information and changed a few lines in Application (app.js) file, saved and closed it. And then I opened it again in order to do some more clean up and this time the project opened without those errors!

    At first I didn't understand that this was the reason, so I did it again in order to confirm that this was the case. I have no idea what the problem was and how it got fixed by just editing + saving app.js but at the end the problem is solved. (Since we are very new to Sencha Architect and Touch, we weren't sure which files to put under source control. So we ignored the metadata folder under our project. While I was trying to figure out the problem I've seen that we shouldn't have ignored metadata folder. I think some more stuff have happened during the upgrade on metadata and I couldn't trace it through file difference.)

    So thanks for offering to check our project... Otherwise I wouldn't copy, edit,.... and get rid of the errors!

    Ipek

  5. #5
    Sencha Premium Member
    Join Date
    Oct 2013
    Posts
    1

    Default Same Problem in version 3.0.3.1382

    i have had the same problem today in version 3.0.3.1382. Views, models and stores are shown twice and a lot of errors "There was an error while loading this instance" are shown.
    I have copied my sencha architect project to another place. When i open that, everything looks normal and no errors appear.
    What is the reason for this?

  6. #6
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    No idea

    We were never able to see/reproduce this. Any steps to reproduce or projects that reproduce the behavior?
    Aaron Conran
    @aconran

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •