Results 1 to 2 of 2

Thread: LocalStorage question

  1. #1
    Sencha User
    Join Date
    Nov 2010
    Vote Rating

    Default LocalStorage question

    LocalStorage docs state the following:
    "If this proxy is used in a browser where local storage is not supported, the constructor will throw an error"
    what is the best way to deal with this?
    should I use Ext.feature.has.LocalStorage to check first? does Ext.feature.has.LocalStorage relates to
    assuming I intend to use IOS and android only as browsers to this application. is there a browser version matrix where I can find from which version local storage is supported? for example (android 2.2+ and ios4+)
    thanks in advance

  2. #2
    Sencha - Support Team
    Join Date
    Oct 2011
    Vote Rating


    Checking he source I see that that error is only thrown in development mode to the console.
    You could create your own function to check as suggested in the following post:

    browser/localstorage support matrix
    Get more personalized support via a support subscription.

    Need more help with your app? Hire Sencha Services

    When posting code, please use BBCode's CODE tags.

    Need to include a test case use:
    The official Sencha Fiddle

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts