Results 1 to 2 of 2

Thread: ItemSelector issues going from 4.1.3 to 4.2.1

  1. #1
    Ext Premium User
    Join Date
    Nov 2013
    Posts
    35

    Default ItemSelector issues going from 4.1.3 to 4.2.1

    We have a working 4.1.3 ItemSelector in a form which submits properly. After upgrading to 4.2.1 the values are no longer submitted on form submit. In debugging we see values using both getValue() and getSubmitValue. We have not found any documentation about this.

    The following is our 4.1.3 code that lives in a form (the only difference in 4.2.1 version was that we removed queryMode as we did not see it referenced anymore in th docs):


    {
    xtype: 'itemselector',
    id: 'history_measures_itemselector',
    itemId: 'history_measures_itemselector',
    hidden: true,
    fieldLabel: 'Information Measures',
    width: 350,
    height: 200,
    store: form.historyStore,
    queryMode: 'local',
    displayField: 'Name',
    valueField: 'Id'
    },

  2. #2
    Sencha Premium User mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    40,448

    Default

    Have you tried the getSubmitData method also? I would set a debugger statement or breakpoint before the form.submit() call and follow the code to understand what the failure is.
    Mitchell Simoens @LikelyMitch

    Check out my GitHub:
    https://github.com/mitchellsimoens

    Posts are my own, not any current, past or future employer's.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •