Results 1 to 5 of 5

Thread: Web server running at startup

  1. #1
    Sencha User
    Join Date
    May 2013
    Location
    Italy
    Posts
    27
    Answers
    5
    Vote Rating
    -2
      -1  

    Default Web server running at startup

    Hallo
    I recently installed a trial of Architect 3 and created a small testing app, which I previewed through an existing webserver (not using Cmd).
    Since then, when I call localhost:1841 I find it is already serving that app, and when I try to stop it I get
    Code:
    [ERR] Connection refused
    .
    When I issue another
    Code:
    sencha web -port 1841 start
    every thing runs fine as if there was no webserver already running on that port.
    Hence, when launch another more "start" I get the correct
    Code:
    [WRN] Error starting jetty: Address already in use
    as expected.
    So there is a jetty running at the system startup, using the 1841 port, but it is somehow "transparent" - anyway it prevails to any other jetty instance and doesn't let me run any other Sencha app.
    Any idea?
    Thanks in advance

    Environment:
    OSX 10.9.1
    Previously installed: Sencha Cmd 3.1.2.342 (uninstalled by the provided uninstaller)
    Sencha Architect 3.0.2.1375
    Cmd 4.0.2.67

  2. #2
    Sencha User
    Join Date
    Jan 2009
    Location
    Frederick, Maryland
    Posts
    925
    Answers
    66
    Vote Rating
    33
      0  

    Default

    My first question would be, do you ever use Cmd from the Cmd Line (outside of Architect). If so, have you started up a "sencha app watch?"
    Jason Minnick
    Sencha Architect Development Team

  3. #3
    Sencha User
    Join Date
    May 2013
    Location
    Italy
    Posts
    27
    Answers
    5
    Vote Rating
    -2
      0  

    Default

    Never.

  4. #4
    Sencha User
    Join Date
    Jan 2009
    Location
    Frederick, Maryland
    Posts
    925
    Answers
    66
    Vote Rating
    33
      0  

    Default

    can you open the help screen in architect and tell us which channel?
    Jason Minnick
    Sencha Architect Development Team

  5. #5
    Sencha User
    Join Date
    Sep 2016
    Posts
    2
    Vote Rating
    0
      0  

    Default

    I have, is there a way I can undo that it's blocking the port

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •