Results 1 to 2 of 2

Thread: Compilation error in Core.gwt.xml

  1. #1
    Sencha Premium Member
    Join Date
    Jul 2011
    Posts
    13

    Default Compilation error in Core.gwt.xml

    Hi,

    I'm trying to migrate my project to GWT 2.6 and GXT 3.1 Beta and I'm running into few problems.
    They might be related to my setup but I thought I'd post the exception in case someone else has seen it.

    This is the exception:

    Code:
    Caused by: java.lang.RuntimeException: Generated message class "com.google.gwt.dev.shell.remoteui.RemoteMessageProto$Message$Builder" missing method "getRequestBuilder".
        at com.google.gwt.dev.protobuf.GeneratedMessage.getMethodOrDie(GeneratedMessage.java:1417)
        at com.google.gwt.dev.protobuf.GeneratedMessage.access$1300(GeneratedMessage.java:57)
        at com.google.gwt.dev.protobuf.GeneratedMessage$FieldAccessorTable$SingularMessageFieldAccessor.<init>(GeneratedMessage.java:1854)
        at com.google.gwt.dev.protobuf.GeneratedMessage$FieldAccessorTable.ensureFieldAccessorsInitialized(GeneratedMessage.java:1511)
        at com.google.gwt.dev.protobuf.GeneratedMessage$FieldAccessorTable.<init>(GeneratedMessage.java:1467)
        at com.google.gwt.dev.shell.remoteui.RemoteMessageProto$1.assignDescriptors(RemoteMessageProto.java:10628)
        at com.google.gwt.dev.protobuf.Descriptors$FileDescriptor.internalBuildGeneratedFileFrom(Descriptors.java:305)
        at com.google.gwt.dev.shell.remoteui.RemoteMessageProto.<clinit>(RemoteMessageProto.java:10853)
    and this is the compilation error:

    Code:
                Loading inherited module 'com.sencha.gxt.ui.GXT'
                   Loading inherited module 'com.sencha.gxt.data.Data'
                      Loading inherited module 'com.sencha.gxt.core.Core'
                         [ERROR] The value ie10 was not previously defined.
                         [ERROR] Line 76: Unexpected exception while processing element 'set-property'
    Has anybody seen these errors before? If so, any help would be much appreciated.

    Thanks,

    Alessandro

  2. #2
    Sencha Premium Member
    Join Date
    Jul 2011
    Posts
    13

    Default

    Hi,

    I found the problem and I'm posting the solution in case someone else has the same issue.

    I had the eclipse plugin installed for GWT 2.5 and when I upgraded it to 2.6 it installed the new GWT 2.6 SDK.

    However, the default SDK to be used (Preferences > Google > Web Toolkit) was left unchanged.

    Hence, when launching the client from eclipse, I was running GXT 3.1 Beta against GWT 2.5 .

    Removing GWT 2.5 SDK and cleaning up the projects fixed the problem.

    Alessandro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •