Results 1 to 5 of 5

Thread: Segmentation fault running Sencha Architect 3.0.2.1375

    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-5589 in Architect 3.1.x.
  1. #1
    Sencha Premium Member
    Join Date
    Mar 2014
    Location
    Madrid, Spain
    Posts
    3

    Default Segmentation fault running Sencha Architect 3.0.2.1375

    I'm getting a segmentation fault when I run Sencha Architect. My OS is Ubuntu 12.04 64 bits. The output I get when I try to run it from command line is this:

    [email protected]:~/SenchaArchitect3$ ./start.sh
    Loading Architect package /home/user/.local/share/Sencha/Sencha Architect 3.0/xds-3.0.2.001375.ion
    Loading Desktop Packager at /home/user/.local/share/Sencha/Sencha Architect 3.0/runtime/sdp-1.3.0.795/SenchaArchitect
    [10215:10215:0331/130054:5132788268:ERROR:zygote_host_impl_linux.cc(146)] Running without the SUID sandbox! See https://code.google.com/p/chromium/w...boxDevelopment for more information on developing with the sandbox on.
    Violacin de segmento (`core' generado)


    where "violacin de segmento" = "Segmentation Fault"

    I've done several tests and I've reached the following conclusions

    - My computer is behind an authenticated HTTP Proxy and the error (the segmentation fault) is always generated after filling the proxy credentials in the prompt window that Architect shows.
    - If I clean both ~HOME/.config/Sencha and ~HOME/.local/share/Sencha and run the program again, the first execution is successful. However, If I close the program and re-launch it, it crashes again.

    Has somebody had the same problem?

    Thanks in advance.

  2. #2
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    Thanks, I moved the thread to the bug forums and have opened a ticket for this.

  3. #3
    Sencha Premium Member
    Join Date
    Mar 2014
    Location
    Madrid, Spain
    Posts
    3

    Default Possible workaround

    In the meantime, the following workaround is possible:

    1. Disable proxy configuration
    2. Run Sencha Architect
    3. Enable proxy configuration again

    To enable/disable the proxy in Ubuntu, you could use these commands:

    Disable: gsettings set org.gnome.system.proxy mode 'none'
    Enable: gsettings set org.gnome.system.proxy mode 'manual'

  4. #4
    Sencha User aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,488

    Default

    Thanks for posting a workaround. Can you tell us a little more information about your proxy, whether it has auth, etc? It will help us track down the bug.
    Aaron Conran
    @aconran

  5. #5
    Sencha Premium Member
    Join Date
    Mar 2014
    Location
    Madrid, Spain
    Posts
    3

    Default

    The only thing I know is that it's an authenticated HTTP proxy. If you need any extra detail, let me know it and I'll try to contact my network admin.

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •