Results 1 to 5 of 5

Thread: azure extension / windows / can not get to load

  1. #1
    Touch Premium Member pkellner's Avatar
    Join Date
    Sep 2008
    Location
    San Jose, California
    Posts
    834
    Vote Rating
    25
      0  

    Default azure extension / windows / can not get to load

    I posted at the end of the last thread regarding my issue with SA3 and architect (with azure extension).

    I tried adding the requires myself in the app.json file. It builds with no errors (sencha app build).

    It does give me an error when SA3 loads (see screen shot) and the extensions are not showing.

    sa3x.jpg

  2. #2
    Sencha Developer
    Join Date
    Sep 2008
    Location
    Antioch, IL
    Posts
    1,516
    Vote Rating
    1593
      1  

    Default

    Hi Peter! Sorry for the delay in responding here, I'm trying to catch up from some time off.

    I have had a few reports of trouble with our Architect extension, so let's start from the beginning:

    (1) Download the most recent version of our package from Sencha Market (https://market.sencha.com/extensions...-windows-azure). There was a bug with a previous version, and sadly there's a bug in the version distributed via Sencha Cmd that kills the Architect integration.

    (2) Take a read through our Guide on where to install the code so that Architect sees it:
    - http://docs.sencha.com/touch-azure/1...uide/architect

    -----

    I saw the comments in the other thread about having trouble on Windows 8.1 with the correct location:
    - http://www.sencha.com/forum/showthre...xt.azure/page2

    As Steve mentions in his reply to you, you can find the correct path by looking in your Architect settings.

    Thus, when all is said and done, you should have things installed something like this:

    C:\users\peterkellner\Documents\Architect\Extensions\touch-azure\1.0.0\

    Let me know if that works.

  3. #3
    Sencha Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    658
    Vote Rating
    40
      0  

    Default

    I'm trying to install this now, and see a blog and video about "version 2" and renaming to sencha-azure.

    However, cmd only sees version 1.0.0.180, both for sencha- and touch-

    I tried to download the newest from the marked (2.0.0.180)
    https://market.sencha.com/extensions...icrosoft-azure

    and copied it tot he SA folder (as I've done with my own extensions) however, it looks like the package.json is missing the architect configuration. architect/ folder is there, with definition files, but package.json does not include the architect:{} config property.

    I guess I could try to reproduce, but if anyone have them already: please post.
    Sven Tore Iversen

  4. #4
    Sencha Developer
    Join Date
    Sep 2008
    Location
    Antioch, IL
    Posts
    1,516
    Vote Rating
    1593
      1  

    Default

    Correct, the version number you get via the Cmd download doesn't match the package.json number... it's a quirk in our deployment process for this.

    And the latest version dropped support for Architect as the architecture, in order to support both Touch and Ext, makes it difficult for Architect to load into its internal canvas.

  5. #5
    Sencha User
    Join Date
    Mar 2007
    Posts
    792
    Vote Rating
    10
      0  

    Default

    Hi any news about how to use Ext.Azure from SA 3.2.0.279 on Win8.1 please?


    regards
    Frank

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •