Results 1 to 3 of 3

Thread: Grid GroupingView Issues

  1. #1
    Sencha User
    Join Date
    Dec 2011
    Posts
    43
    Vote Rating
    8
      0  

    Default Grid GroupingView Issues

    I have two separate versions of code for my application. The first picture below is from my older version. I made multiple changes to my code since the first picture and the label in the second picture is now not displaying correctly. I am having trouble figuring this one out because the files for this grid are the same in both versions of my code. This component has not had changes to it for a long time, so I am not sure why this started happening.
    after.png
    before.png

    This has always been the code.
    Code:
    this.view = new Ext.grid.GroupingView({
                forceFit: true,
                hideGroupedColumn: true,
                enableGroupingMenu: false,
                groupTextTpl: 'Household',
                deferEmptyText: false,
                emptyText:'No parties at location on file.'
            });
    As a temp fix this seems to help,

    Code:
            this.view = new Ext.grid.GroupingView({
                forceFit: true,
                hideGroupedColumn: true,
                enableGroupingMenu: false,
                groupTextTpl: '       Household',
                deferEmptyText: false,
                emptyText:'No parties at location on file.'
            });
    I don't think this is a browser issue because if I deploy my old code it still works fine. As always, any suggestions are appreciated. Thanks!

  2. #2
    Sencha - Support Team
    Join Date
    Feb 2013
    Location
    California
    Posts
    9,816
    Vote Rating
    260
      0  

    Default

    You shouldn't have to do something like that. So you're using the same version of ExtJS with each of the two versions of your application?


    Join me at SenchaCon 2016!

  3. #3
    Sencha User
    Join Date
    Dec 2011
    Posts
    43
    Vote Rating
    8
      0  

    Default

    My versions of Ext JS have been the same, always 3.4. I have made multiple code changes between the two releases, but no changes to the fields in question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •