Results 1 to 3 of 3

Thread: How to check that if detected browser is firefox 3.6+ ?

  1. #1
    Sencha User
    Join Date
    Jun 2011
    Location
    Bangalore, India
    Posts
    180
    Answers
    4

    Default How to check that if detected browser is firefox 3.6+ ?

    Hi All,

    I want to check that browser detected is firefox 3.6+

    Is the following code is right way to do that ?

    Code:
    if(Ext.firefoxVersion >= 3.6)
        {
           // do stuff
        }
    else
    {
    // alert not supported browser
    }
    Please suggest the efficient way to do
    Thanks,

    RENGANATHAN M G

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Seems like the way to do this. Is it working for you?

  3. #3
    Sencha Premium Member
    Join Date
    Oct 2012
    Posts
    56
    Answers
    2

    Default

    Try Ext.isFF3_6

    if still not work then go native


    navigator.sayswho= (function(){ var ua= navigator.userAgent, tem, M= ua.match(/(opera|chrome|safari|firefox|msie|trident(?=\/))\/?\s*(\d+)/i) || []; if(/trident/i.test(M[1])){ tem= /\brv[ :]+(\d+)/g.exec(ua) || []; return 'IE '+(tem[1] || ''); } if(M[1]=== 'Chrome'){ tem= ua.match(/\bOPR\/(\d+)/) if(tem!= null) return 'Opera '+tem[1]; } M= M[2]? [M[1], M[2]]: [navigator.appName, navigator.appVersion, '-?']; if((tem= ua.match(/version\/(\d+)/i))!= null) M.splice(1, 1, tem[1]); return M.join(' ');})();

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •