Results 1 to 4 of 4

Thread: Tree store proxy url appends 'root' while using REST Proxy

  1. #1
    Sencha User
    Join Date
    Sep 2008
    Posts
    31
    Vote Rating
    3
      0  

    Default Tree store proxy url appends 'root' while using REST Proxy

    Hi,

    I have a tree grid, with columns defined.
    I am not specifying any root node.
    In tree store, its rest proxy and url is define as 'rest/myrul'.

    But whenever I load the tree store, it appends 'root' in the url as 'rest/myurl/root'.

    I read from docs it appends root node id to the url.

    How can I get rid of this?
    Kindly help.

  2. #2
    Sencha User slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    6,165
    Answers
    505
    Vote Rating
    255
      0  

    Default

    Hi,

    Try setting appendId to false in the REST proxy config:
    http://docs.sencha.com/extjs/4.2.2/#...t-cfg-appendId

  3. #3
    Sencha User
    Join Date
    Sep 2008
    Posts
    31
    Vote Rating
    3
      0  

    Default

    Hi,

    Thanks for the reply.
    I need 'appendId' property to be true for rest of records, as the child records are loaded from that.

    I found that 'defaultRootId' property to '', seemed to worked. it dint append 'root' to the url

  4. #4
    Ext JS Premium User
    Join Date
    Jan 1970
    Posts
    12
    Vote Rating
    2
      0  

    Default

    Same problem here. We can't set appendId to false as we have to send the ID for the update and the deletion operations. But we would like to remove the ID in the url for the GET operation.

    How could we do that properly please?

    Edit: BTW, the workaround consisting in setting defaultRootId to '' doesn't work in ExtJS 5.1 : a generic root id is defined (based on the class name of the model this time).

    Florent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •