Results 1 to 4 of 4

Thread: trackChanges never enabled on store used to reconfigure a table

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Vote Rating
    108
      0  

    Default trackChanges never enabled on store used to reconfigure a table

    store.trackChanges is set to true in the constructor for a table.
    When you reconfigure this does not get called.

    Shouldn't it happen in bindStore?

    Cheers,
    Westy
    Product Architect
    Altus Ltd.

  2. #2
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Vote Rating
    108
      0  

    Default

    I now have my reconfigured grid remembering the filter!

    My override:
    Code:
            bindStore: function() {
                var me = this;
    
    
                me.callParent(arguments);
                me.store.trackStateChanges = true;
            }
    Unfortunately the filter plugin itself does not reflect the filter when restoring state... so that's the next problem!
    Arrgghhhh...
    .
    Cheers,
    Westy
    Product Architect
    Altus Ltd.

  3. #3
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Vote Rating
    108
      -1  

    Default

    Quote Originally Posted by westy View Post
    Unfortunately the filter plugin itself does not reflect the filter when restoring state... so that's the next problem!
    Seems that the state of the store is not restored before the constructor on the filter plugin instance!
    I'd be amazed if anyone has got filtering working on a reconfigured grid, since it's just one problem after another...
    Product Architect
    Altus Ltd.

  4. #4
    Sencha Premium User westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    1,037
    Vote Rating
    108
      0  

    Default

    This still looks to be an issue in 6.7.0 too.
    Product Architect
    Altus Ltd.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •