Results 1 to 4 of 4

Thread: Filtering & Pagination in the Grid is not working properly for Internet Explorer

  1. #1

    Default Filtering & Pagination in the Grid is not working properly for Internet Explorer

    Hello,

    In my application we are using the Grids for 2-3 screens, which is holding the data. when we are viewing the application in Mozilla or Chrome everything is working fine including the pagination and the Filtering. But the same application when i am viewing in the Internet Explorer the Filtering and Pagination is not working and when i try to move to the next page it is altering the page nos. but not reloading the grid data.

    I am not using any user agents in my gwt.xml as i want it to be for all the browsers.

    Please recommend something to be done to fix for Internet Explorer as well. I am using gxt3.0.1 for my application.

    Rahul Anand

  2. #2
    Sencha Premium Member
    Join Date
    Jul 2014
    Posts
    20
    Answers
    2

    Default

    Hello Rahul,

    I'm using the same combination and for me it's working just fine.

    Please provide your code to have a look on it.

    Sven

  3. #3

    Default

    Hello Sven,

    It`s working for me as well when i am running it in the Local for all the Browsers including Internet Explorer.

    But, when I deploy the code in the LINUX Environment, then the Filtering and Pagination stuffs gets some problems for one of the Screen.

    Actually when i am moving in the next page its altering the Page no`s but the Grid data does not get refreshed.
    The same follows for the Filtering also, when ever I am filtering by any keyword then it refreshes the Grid but filters does not get applied.

    But this problem is not seen in any other Browser except Internet Explorer.

    Rahul Anand

  4. #4
    Sencha User
    Join Date
    Jul 2011
    Location
    Germany
    Posts
    223
    Answers
    5

    Default

    Rahul, I guess u should gather more info to see what exactly is the problem.
    Did u track the request, that fails with IE? Would be helpful to know if Server returns an error.
    If not, there is something u can do on clientside: I am sure u use some kind of PagingLoader. Do u add a ExceptionHandler?
    I do something like this in my webapp:
    Code:
            pagingLoader.addLoadExceptionHandler(new LoadExceptionHandler<FilterPagingLoadConfig>() {
                @Override
                public void onLoadException(
                        LoadExceptionEvent<FilterPagingLoadConfig> event) {
                    grid.getView().setEmptyText("data retrieval failed!");
                    grid.getStore().clear();
                }
            });
    This way user gets informed about a communication problem and outdated data gets removed from grid.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •