Results 1 to 8 of 8

Thread: bootstrap.js not found 404 error architect 3.1

  1. #1
    Sencha User
    Join Date
    Dec 2010
    Posts
    83

    Default bootstrap.js not found 404 error architect 3.1

    Hello,
    I just installed 3.1 on my mac. When ever I create a new project and publish it, I get a bootstrap.js not found 404 error in the browser. Projects upgraded from 3.0 work fine. Any ideas?

  2. #2
    Sencha User
    Join Date
    Nov 2011
    Posts
    28
    Answers
    1

    Default

    i had the same problem (with windows)... the point is: the bootstrap.js is not there when you "publish" something, for me it looks like, its only there, when you really "build" the app... if the "build app" button is disabled - doesnt matter what you try, maybe my posting does help you....

  3. #3
    Sencha User
    Join Date
    Dec 2010
    Posts
    83

    Default

    Thanks for the reply. Because I have never had to 'build' a project before doing a test publish in architect 3.0 and because the bootstrap.css is copied and bootstrap.js is listed in the index.html, I feel this is a bug. Unless I am doing something wrong or I failed to set something up correctly. But again, never had any problems with 3.0. I wish there would be an official response to this from a sencha employee.
    Thanks again for the reply.

  4. #4
    Sencha Premium Member
    Join Date
    Sep 2012
    Location
    Tokyo
    Posts
    13
    Answers
    2

    Default

    I also had the same problem but it solved when updating the version of JDK to 7 from 6.

  5. #5
    Sencha User
    Join Date
    Dec 2010
    Posts
    83

    Default

    Thanks Yukiozek,
    Upgrading the JDK solved the problem just as you suggested.

  6. #6
    Sencha Premium Member
    Join Date
    Jan 2013
    Posts
    59
    Answers
    1

    Default

    I had a similar problem today with bootstrap.js not being generated by Sencha Architect even after rebuild etc. It was subtle, but ultimately my fault. My Ext.application had a requires:[] pointing to an override class that didn't exist in the filesystem.

    The log console output did show this in Architect, and restoring the missing override JS allowed it to generate bootstrap.js again OK.

  7. #7
    Sencha User
    Join Date
    Jan 2014
    Posts
    22
    Answers
    1

    Default Building solved the problem

    I had this problem and the bootstrap.js didn't appear until I built the application.

  8. #8
    Sencha User
    Join Date
    May 2014
    Posts
    22
    Answers
    4

    Default

    That absolutely seems like a bug. Especially since it dind't happen in earlier versions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •