1. #1
    Sencha User
    Join Date
    Nov 2012
    Posts
    15
    Vote Rating
    0
    Rockz is on a distinguished road

      0  

    Default Extjs5 packaging is giving exception

    Hi All,

    I am trying to do POC for code packaging in EXTJS5. For that i have created the package in sencha cmd 5.0.2.270. In to the src folder i have added a file with the following content.
    Ext.define('foo.Easy', {
    extend: 'Ext.button.Button',
    xtype: 'easybutton',
    //ui: 'easy',
    requires: [
    'Ext.window.MessageBox'
    ],
    handler: function() {
    Ext.Msg.alert('Easy', 'That was easy!');
    }
    });

    Now i have build the package . It is succcesful and am able to add the package to the local repository. Now am trying to use the button in one more application.

    In the application, app.json file requires filed added the foo pkg
    "requires": [
    "foo"
    ],
    In the view file am trying to access the button
    {
    region : 'south',
    xtype : 'easybutton',
    height: 200
    }

    I'am getting the following exception
    [ERR] Failed to resolve dependency Ext.dataview.DataView for file Ext.chart.LegendBase
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExNotFound: Unknown definition for dependency : Ext.dataview.DataView
    [ERR] at java.lang.reflect.Method.invoke(Unknown Sourc
    [ERR] e)
    [ERR]
    [ERR] Total time: 49 seconds
    [ERR] The following error occurred while executing this line:
    C:\Users\tsabat\Desktop\sept22\myworkspace\myApp\.sencha\app\build-impl.xml:246: The following error occurred while executing this line:
    C:\Users\tsabat\Desktop\sept22\myworkspace\myApp\.sencha\app\watch-impl.xml:56: The following error occurred while executing this line:
    C:\Users\tsabat\Desktop\sept22\myworkspace\myApp\.sencha\app\build-impl.xml:376: The following error occurred while executing this line:
    C:\Users\tsabat\Desktop\sept22\myworkspace\myApp\.sencha\app\init-impl.xml:292: com.sencha.exceptions.ExNotFound: Unknown definition for dependency : Ext.dataview.DataView


    Can anyone know what is the problem.

    Any help is highly appreciated

    Thanks in Advance

  2. #2
    Sencha Premium Member
    Join Date
    Mar 2007
    Posts
    100
    Vote Rating
    34
    ismoore has a spectacular aura about ismoore has a spectacular aura about

      0  

    Default

    Is this all of your code? Are you using charts anywhere?

  3. #3
    Sencha User
    Join Date
    Nov 2012
    Posts
    15
    Vote Rating
    0
    Rockz is on a distinguished road

      0  

    Default

    Hi,Ya i have used charts in my package, but while building the package it has not given any error and when using the package then its giving error to me.ThanksRockz

  4. #4
    Sencha User
    Join Date
    Jan 2011
    Posts
    6
    Vote Rating
    0
    Futch is on a distinguished road

      0  

    Default Did you resolve this issue?

    Failed to resolve dependency Ext.dataview.DataView for file Ext.chart.LegendBase

Thread Participants: 2

Tags for this Thread