Results 1 to 4 of 4

Thread: Ext.isIE9m holds in IE11

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium User alexander.urban's Avatar
    Join Date
    Nov 2013
    Posts
    324

    Default Ext.isIE9m holds in IE11

    I am using ExtJS 4.2.3 commercial, because I hoped for better support for IE11 in the all-brand-new Ext 4.2.3. My IE11 reports the following when opening a website for render inside Outlook 2013:


    navigator.useragent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64, Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Microsoft Outlook 15.0.4615)
    document.documentMode: 11


    which means that isIE7 holds because your check obviously does not recognize documentModes higher than IE10:


    Code:
    isIE7 = (isIE && ((check(/msie 7/) && docMode != 8 && docMode != 9 && docMode != 10) || docMode == 7),

    Now, if it was a IE10 reporting the same UA with document.documentMode=10, it would correctly be recognized as IE10, so I guess you forgot to add full support for IE11 into ExtJS 4.2.3 - nearly one year after IE11 went live.

    I didn't check, but my guess is this bug is also present in the most recent version of ExtJS 5.

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Thanks for the report. Not sure I'm understanding entirely. You're getting a false positive for isIE9 when using IE11? Can you please post a test case which exhibits the issue?
    https://fiddle.sencha.com/#home

  3. #3
    Sencha Premium User alexander.urban's Avatar
    Join Date
    Nov 2013
    Posts
    324

    Default

    I am getting a false positive for isIE7, and therefore, for isIE9m.

    The error seems to be the same that is reported by nbabinski:

    http://www.sencha.com/forum/showthread.php?221235-IE-9-dom.all-id-error&p=1067311&viewfull=1#post1067311

  4. #4
    Sencha Premium User alexander.urban's Avatar
    Join Date
    Nov 2013
    Posts
    324

    Default

    Update: I have heard from Sencha Support that the bug will finally be fixed in ExtJS 6.5.1.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •