Results 1 to 3 of 3

Thread: Dirty Record indicator not working when using renderer with all parameters.

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium Member
    Join Date
    Mar 2013
    Posts
    14

    Default Dirty Record indicator not working when using renderer with all parameters.

    I have a gridcolumn with an editor and a renderer with all parameters (value, metadata, record, rowIndex, colIndex, store, view). When I edit the value of the column, the red dirty indicator vanishes. Using a renderer with "value" as the only parameter works correctly. See this fiddle for an example: https://fiddle.sencha.com/#fiddle/bp2

    There's also a problem with summary. In the same fiddle, the alert shown after edit shows the value of the summary, but the corresponding cell on the grid is never updated.

    Is there any workaround for this bugs?

    Edit: a possible workaround is adding the following "endupdate" listener to the store:

    Code:
    function (eOpts) {
       var grid = CODE_TO_GET_THE_GRID    
       grid.getView().refresh();
    }

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Thanks for the report. I'm not able to recreate the dirty record issue. For me, edited cells are marked appropriately no matter what I try. In which browser are you seeing this?

  3. #3
    Sencha Premium Member
    Join Date
    Mar 2013
    Posts
    14

    Default

    Google Chrome 38.0.2125.101 m (64-bit). Thanks for replying!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •