Results 1 to 3 of 3

Thread: Upgrade from extjs 4.1.1.1 to extjs 5.0.1 using Sencha cmd

  1. #1
    Sencha User
    Join Date
    Mar 2010
    Posts
    37

    Default Upgrade from extjs 4.1.1.1 to extjs 5.0.1 using Sencha cmd

    Hello,
    I wanted to improve old extjs application developed in extjs 4.1 and decided to upgrade it to latest framework.

    Ext.getVersion().version returns 4.1.1.1 as my current extjs. Cmd documentation says that my app should be built using 4.1.1a+.

    First question: Is 4.1.1.1 == 4.1.1.1a, or do I need to upgrade 4.1.1.1 to something before proceeding to 5?

    If my library version is sufficient I have following question:
    What does the following errors mean? I get them while running command in the root of my app.

    Code:
    Inspiron-3721:~/web/ks$ sencha -sdk lib/ext-5.0.1 generate app upgrade
    Sencha Cmd v5.0.3.324
    [ERR] Missing required arguments.
        
        sencha.generate.app requires these parameters:
        
        path (The path for the generated application)
        
        For usage info, see
        
        sencha help generate app
    [ERR] 
    The application was last modified by an older version of Sencha Cmd (5.0.1.231)
    the current is 5.0.3.324.
    Please run "sencha package upgrade" to update to 5.0.3.324.
    Last edited by papaja; 30 Oct 2014 at 10:15 AM. Reason: Small correction in title

  2. #2
    Sencha Premium Member
    Join Date
    Sep 2014
    Posts
    7

    Default

    I think the correct command would be:
    Code:
    sencha -sdk lib/ext-5.0.1 app upgrade
    Just drop the "generate" and you're good to go.

  3. #3
    Sencha User
    Join Date
    Mar 2010
    Posts
    37

    Default

    Thank you for your reply. WHen I dropped generate I get following errors:
    Code:
    Inspiron-3721:~/web/ks$ sencha -sdk lib/ext-5.0.1 app upgrade
    Sencha Cmd v5.0.3.324
    [ERR] Command must be run from an application folder
    [ERR] 
    The application was last modified by an older version of Sencha Cmd (5.0.1.231)
    the current is 5.0.3.324.
    Please run "sencha package upgrade" to update to 5.0.3.324.
    It seems that I am missing some files in my application folder since it cannot recognise it as such. How does this tool determine if it is in app folder or not?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •