Results 1 to 8 of 8

Thread: not run sencha architect 3 in linux

  1. #1

    Default not run sencha architect 3 in linux

    Disclaimer sencha architect 3 from the official website.
    I run the .run file.
    The application is installed normally.
    But when I click the desktop file, nothing happens, then run the file start.sh and only I get this in console:

    [email protected]:/opt/SenchaArchitect3$ sh start.sh
    start.sh: 8: start.sh: oldDataDirs[0]=/home/daniel/.local/share/Sencha, Inc./Sencha Architect 2.0: not found
    start.sh: 9: start.sh: oldDataDirs[1]=/home/daniel/.local/share/Sencha, Inc./Sencha Architect 2.1: not found
    start.sh: 10: start.sh: oldDataDirs[2]=/home/daniel/.local/share/Sencha/Sencha Architect 2.2: not found
    start.sh: 11: start.sh: oldDataDirs[3]=/home/daniel/.local/share/Sencha/Sencha Architect 2.3: not found
    start.sh: 12: start.sh: oldDataDirs[4]=/home/daniel/.local/share/Sencha/Sencha Sencha Architect 3.0: not found
    start.sh: 20: start.sh: Bad substitution


    I not run the application...

    if they could help me, thank you very much in advance.

  2. #2
    Sencha User Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,953

    Default

    Is this a fresh install? What brand of Linux are you running?
    Phil Strong
    @philstrong

  3. #3
    Sencha Premium Member
    Join Date
    Oct 2013
    Posts
    42

    Default

    Exactly the same here.

    Version:

    Code:
    lsb_release -a
    
    Distributor ID:    Ubuntu
    Description:    Ubuntu 14.04.1 LTS
    Release:    14.04
    Codename:    trusty

  4. #4
    Sencha User Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,953

    Default

    Can you run bash ./start.sh?

    I wonder if this is not bash running this script?
    Phil Strong
    @philstrong

  5. #5
    Sencha Premium Member
    Join Date
    Sep 2014
    Posts
    87

    Default

    Here under Lubuntu (based on 14.04) I get the message, that libudev.so.0 could not be found ...

  6. #6
    Sencha Premium Member
    Join Date
    Sep 2014
    Posts
    87

    Default

    A possible workaround can be found here: http://askubuntu.com/questions/28882...dev-so-0-error

  7. #7
    Sencha Premium Member
    Join Date
    Oct 2013
    Posts
    42

    Default

    >>I wonder if this is not bash running this script?
    Y r right. Thx.

  8. #8

    Default hi

    if it is a new install.
    and I am using debian 2014

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •