Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Disable dataview scroll when select + dblclick selection

  1. #11
    Sencha User
    Join Date
    Apr 2016
    Posts
    54
    Answers
    3

    Default

    Quote Originally Posted by mistik1 View Post
    This new selection feature in v5 is killing us over here.

    I am being affected by this problem in my grid with rowexpander, if you have a large rowbody the grid will always scroll back to the top of the row when you click anything inside the rowbody, why in the world does the expander icon need to take focus along with every cell in my grid?

    I have no cell based selection model yet they all take focus away from my rowbody.

    How do I turn off the aria focusing behavior, v5 has made my grids useless?
    Any fix for this yet? Adding "focusable: false" to my grid didn't do a bit of good and it's killing us, too.

  2. #12
    Sencha Premium Member
    Join Date
    Mar 2014
    Posts
    63
    Answers
    2

    Default

    Not sure if anyone still cares, but from my investigations, you need to set focusable: false on the viewConfig of a grid. Setting it on the grid itself does not work.

    Example:

    Code:
    Ext.create(Ext.grid.Panel', {
    store: store, viewConfig:{
    focusable: false
    }
    });
    For me this works for grids. For dataviews, as Zdeno wrote, focusable: false works to stop scrolling to the selected row.

  3. #13
    Sencha User
    Join Date
    Apr 2016
    Posts
    54
    Answers
    3

    Default

    Quote Originally Posted by LailaAgaev View Post
    Not sure if anyone still cares, but from my investigations, you need to set focusable: false on the viewConfig of a grid. Setting it on the grid itself does not work.

    Example:

    Code:
    Ext.create(Ext.grid.Panel', {
    store: store, viewConfig:{
    focusable: false
    }
    });
    For me this works for grids. For dataviews, as Zdeno wrote, focusable: false works to stop scrolling to the selected row.
    I added this to both the containing grid and the embedded grid, then a combination of either one or the other. Neither worked.

    My ulitmate "fix" was making the data more compact to fit within the view, so the users wouldn't have to do any scrolling unless the windows were really small. Still broken in my opinion

  4. #14
    Sencha Premium User wemerson.januario's Avatar
    Join Date
    Nov 2008
    Location
    Goiânia - GO, Brazil
    Posts
    898
    Answers
    15

    Default

    for those who are looking for something similar for modern toolkit, here it is! itemsFocusable: false
    Wemerson Januario @JanuarioCoder
    Novanti Tecnologia, Sencha MVP/ Ext JS Consultant
    ____________________________________________
    Hire me on UpWork:

    GitHub
    https://github.com/wemersonjanuario

    Treinamento e Consultoria Ext JS. QUALIFIQUE-SE JÁ!

  5. #15
    Sencha Premium User NoahK17's Avatar
    Join Date
    Apr 2008
    Location
    Atlanta, GA
    Posts
    538

    Default

    Confirmed. For ExtJS 6.6.x, using itemsFocusable: false will stop Dataview items off-screen from scrolling into view on tap events.
    Noah
    Front-End Developer
    Norfolk Southern

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •