Results 1 to 7 of 7

Thread: Production issue ("importPackage" is not defined in <eval> at line number 1)

  1. #1

    Default Production issue ("importPackage" is not defined in <eval> at line number 1)

    While I am creating production version of Sencha Touch app with Sencha Cmd v3.1.2.342 I am getting following issue:

    www/.sencha/app/build-impl.xml:120: javax.script.ScriptException: ReferenceError: "importPackage" is not defined in <eval> at line number 1


    Here is the whole log data:


    deepmac:www pratik$ ~/bin/Sencha/Cmd/3.1.2.342/sencha app build production
    Sencha Cmd v3.1.2.342
    [INF]
    [INF] init-plugin:
    [INF]
    [INF] cmd-root-plugin.init-properties:
    [INF]
    [INF] init-properties:
    [INF]
    [INF] init-sencha-command:
    [INF]
    [INF] init:
    [INF]
    [INF] app-build-impl:
    [INF]
    [INF] -before-init-local:
    [INF]
    [INF] -init-local:
    [INF]
    [INF] -after-init-local:
    [INF]
    [INF] init-local:
    [INF]
    [INF] find-cmd:
    [INF]
    [INF] -before-init:
    [INF]
    [INF] -init:
    [INF] Initializing Sencha Cmd ant environment
    [INF] Adding antlib taskdef for com/sencha/command/compass/ant/antlib.xml
    [INF]
    [INF] -after-init:
    [INF]
    [INF] init:
    [INF]
    [INF] -before-build:
    [INF]
    [INF] sass:
    [INF]
    [INF] -before-sass:
    [INF]
    [INF] -sass:
    [INF] [shellscript] identical ../css/app.css
    [INF]
    [INF] -after-sass:
    [INF]
    [INF] page:
    [INF]
    [INF] -before-page:
    [INF]
    [INF] -page:
    [ERR] The following error occurred while executing this line:
    /Applications/MAMP/htdocs/PBI/App/PBIFinalSubmitted/www/.sencha/app/build-impl.xml:126: The following error occurred while executing this line:
    /Applications/MAMP/htdocs/PBI/App/PBIFinalSubmitted/www/.sencha/app/build-impl.xml:120: javax.script.ScriptException: ReferenceError: "importPackage" is not defined in <eval> at line number 1


    Please help...

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Sounds like this issue:
    http://www.sencha.com/forum/showthread.php?245489

    Do you have characters in your code that might cause this? If the workaround in the thread doesn't work, you might try upgrading to a more recent version of Cmd, which seemed to do it for some users.

  3. #3
    Sencha User dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,748

    Default

    What Java version do you have? Might be the same issue as http://www.sencha.com/forum/showthre...-phonegap-init
    Don Griffin

    "Use the source, Luke!"

  4. #4

    Default java version "1.8.0_25"

    java version "1.8.0_25"
    Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
    Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)


    Using Macmini OS X Usemite version 10.10

  5. #5
    Sencha User dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,748

    Default

    OK, yes. The new JavaScript (Nashorn) engine in Java 8 broke Sencha Cmd 3 and 4. You can use Java 7 or upgrade to Cmd 5 to get around this.
    Don Griffin

    "Use the source, Luke!"

  6. #6

    Default

    Thanks...
    I am trying that and let you know soon.

  7. #7

    Default

    Thanks...

    I am able to generate production version of app with Java 7 and same Sencha cmd that is 3.1.2.342. No need to upgrade sencha to cmd 5.

    Again thank you so much for your help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •