Results 1 to 5 of 5

Thread: SA31: Theme ID regenerate cause custom theme not found

  1. #1
    Sencha Premium Member
    Join Date
    Sep 2012
    Location
    Singapore
    Posts
    54
    Answers
    3

    Exclamation Answered: SA31: Theme ID regenerate cause custom theme not found

    Hi,

    I am using SA3.1 and created a project that have custom CSS.
    From MyNeptuneTheme I have added a SCSS Resource.
    SA then stored the custom theme in

    projectname\theme\ext-theme-neptune-8700db2f-84a6-4b7c-b27a-02cb41e69af1.css

    I then zipped the project folder and open it on another PC.

    When I open this project and tried to compile it, it says

    [ERR] Theme "ext-theme-neptune-f0adfe8a-59f0-4416-bee7-207a7e56fbf5" not found

    Notice the name of the custom CSS. It has changed. App.json has changed the name and it definitely could not find the original CSS that comes with the project.

    I tried editing the App.json to the old CSS file, but it get overwritten to the new id every time I save the project.

    Is there something I missed? or is that a bug?

    The only painful way to resolve this is to delete the theme, save it. Load it and then put the theme back and change all the theme settings one by one.

    Please advise.

  2. Could you try the following?

    After you open the archive on your windows machine, save it as a new project. After you do, find .sencha folder in the project folder and remove it (or rename it to back it up), and then in Architect click Save to save project again. This should regenerate all the sencha configs from scratch. Try building the project afterwards, and let me know if you are still encountering the error with the theme.

  3. #2
    Sencha User
    Join Date
    Apr 2012
    Posts
    304
    Answers
    23

    Default

    Hi,

    Could you let me know the framework version in your project, CMD version, and what OS are both computers that you worked with?

    If you let me know I will see to reproduce this and come up with a solution.

  4. #3
    Sencha Premium Member
    Join Date
    Sep 2012
    Location
    Singapore
    Posts
    54
    Answers
    3

    Default

    My Designer is using Mac
    SA: 3.1.0 Build 1934
    ExtJS: 5.1
    Cmd: 5.1.0.26

    I'm using Windows 7
    SA: 3.1.0 Build 1934
    ExtJS: 5.1
    Cmd: 5.1.0.26

    Steps
    1. Create Project on Mac. Create views and add SCSS resource to customise theme. Save project and Archived Project.
    2. Send Archived to Windows 7 (Email).
    3. Using SA in Windows, open archived project. Save project. Error Theme not found.

  5. #4
    Sencha User
    Join Date
    Apr 2012
    Posts
    304
    Answers
    23

    Default

    Could you try the following?

    After you open the archive on your windows machine, save it as a new project. After you do, find .sencha folder in the project folder and remove it (or rename it to back it up), and then in Architect click Save to save project again. This should regenerate all the sencha configs from scratch. Try building the project afterwards, and let me know if you are still encountering the error with the theme.

  6. #5
    Sencha Premium Member
    Join Date
    Sep 2012
    Location
    Singapore
    Posts
    54
    Answers
    3

    Default

    Thank you. It works.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •