Results 1 to 5 of 5

Thread: Install of Jetbrains plugin for Sencha ExtJS into WebStorm 10.0.1 fails on OSX

  1. #1
    Touch Premium Member
    Join Date
    Apr 2007
    Posts
    26

    Default Answered: Install of Jetbrains plugin for Sencha ExtJS into WebStorm 10.0.1 fails on OSX

    When trying to install the new ExtJS plugin into WebStorm 10.0.1 it hangs and WebStorm will not launch.

    Note: If you remove the plugin from ..Library/Application Support/WebStorm10, then WebStorm will launch.

    Cannot attach crash report as too long for forum attachments, so here is initial details:

    Date/Time: 2015-04-09 10:24:20 -0700
    OS Version: 10.9.5 (Build 13F1066)
    Architecture: x86_64
    Report Version: 18

    Command: WebStorm
    Path: /Applications/WebStorm.app/Contents/MacOS/webstorm
    Version: 10.0.1 (WS-141.506)
    Parent: launchd [811]

    PID: 2805
    Event: hang
    Duration: 5.56s
    Steps: 56 (100ms sampling interval)

    Hardware model: MacBookPro11,3
    Active cpus: 8
    Fan speed: 2156 rpm

    Free pages: 2511907 pages (-8484)
    Pageins: 1 pages
    Pageouts: 0 pages
    Swapins: 0 pages
    Swapouts: 0 pages


    Process: webstorm [2805]
    Path: /Applications/WebStorm.app/Contents/MacOS/webstorm
    Architecture: x86_64
    Parent: launchd [811]
    UID: 501
    Task size: 49182 pages (+77)
    CPU Time: 0.087s

  2. A new version, 0.1.211, is available which fixes this issue. You can download it by selecting "Check for Updates..." from the IDE menu.

  3. #2
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    I noticed this once or twice over the last few weeks after installing a new version of the plugin. When it happened I would just kill the WebStorm process and try again. It always seemed to work the second time around and would never have a problem after that. I'm not sure if this is due to the Ext JS plugin specifically, or maybe just a bug in WebStorm 10 in general. It might be due to initial indexing of the app or just running with a new plugin for the first time. I will investigate further.

  4. #3
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Found the problem. A new version should be up Friday, 4/10.

  5. #4
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    A new version, 0.1.211, is available which fixes this issue. You can download it by selecting "Check for Updates..." from the IDE menu.

  6. #5
    Touch Premium Member
    Join Date
    Apr 2007
    Posts
    26

    Default

    Thanks for the quick work Mark! WebStorm, for me, is now running with your latest Sencha ExtJS (0.1.211) plugin.

Similar Threads

  1. Does focus on JetBrains mean the Eclipse plugin is dead?
    By firefoxSafari in forum Community Discussion
    Replies: 5
    Last Post: 1 May 2015, 12:50 PM
  2. JetBrains plugin - sdk
    By firefoxSafari in forum JetBrains IDE Plugin
    Replies: 1
    Last Post: 9 Apr 2015, 11:15 AM
  3. Replies: 3
    Last Post: 22 May 2013, 8:05 AM
  4. Install Sencha Touch and SDK fails on OSX
    By element12 in forum Sencha Touch 2.x: Q&A
    Replies: 2
    Last Post: 13 Nov 2012, 2:33 PM
  5. Can't install the Sencha Eclipse Plugin
    By quamat in forum Ext: Q&A
    Replies: 1
    Last Post: 17 Sep 2012, 9:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •