Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: Plugin suggestions

    You found a bug! We've classified it as IDEAPLUGIN-260 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #31
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Yep, that was it.

    Code:
        
    /**     
     * The toolkit to use. Select either "classic" or "modern".
     */
    should be replaced with

    Code:
        
    /**     
     * The toolkit to use. Select either "classic" or "modern".
     */
    "toolkit": "classic",
    You'll need to restart the IDE once you make that change.

  2. #32
    Sencha User jcvetkovic's Avatar
    Join Date
    May 2012
    Location
    Kragujevac, Serbia
    Posts
    25

    Default

    This is a thing we were missing.

    Thanks a lot Mark.
    J Cvetkovic, Development Lead @ Emisia

  3. #33
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Awesome, glad it's working! If you use the plugin to create your apps in the future, it offers a toolkit selection dropdown where you can pick universal, classic, or modern and automatically sets that field in app.json.

  4. #34
    Sencha User jcvetkovic's Avatar
    Join Date
    May 2012
    Location
    Kragujevac, Serbia
    Posts
    25

    Default

    Hi Mark,
    One more issue remains after adding toolkit to app.json file.
    Any class that overrides some other class is grayed out, if added to requires array.

    In app folder I have patch folder where I put all my overrides, should I use overrides folder instead or should this work either way?

    If is of any help if I write overrides (with s) instead of override, plugin finds that class, but this way override is not working.
    J Cvetkovic, Development Lead @ Emisia

  5. #35
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Can you paste an example of one of your overrides?

  6. #36
    Sencha User jcvetkovic's Avatar
    Join Date
    May 2012
    Location
    Kragujevac, Serbia
    Posts
    25

    Default

    Here is one simple example...

    Code:
    /**
     * WebUI Form Panel Override *
     * @author me
     */
    Ext.define('GS4TR.patch.Form', {
        override: 'Ext.form.Panel',
        
        isValid: function(){
            return this.m_validateAllFields(this);
        }
    });
    J Cvetkovic, Development Lead @ Emisia

  7. #37
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    You should not need to require overrides at all. They are automatically loaded by the framework when the overridden class is loaded. That said, I could probably make the plugin not complain about overrides in the requires array, but they are really unnecessary.

Page 4 of 4 FirstFirst ... 234

Similar Threads

  1. Some UI suggestions
    By blomasky in forum Sencha Architect 3.x: Q&A
    Replies: 0
    Last Post: 19 Sep 2014, 11:50 AM
  2. Feature suggestions for Ext.plugin.PullRefresh
    By jweber in forum Sencha Touch 2.x: Discussion
    Replies: 1
    Last Post: 26 May 2012, 3:47 AM
  3. Replies: 22
    Last Post: 13 Sep 2009, 5:13 PM
  4. Several suggestions
    By tjcrowder in forum Community Discussion
    Replies: 0
    Last Post: 4 Nov 2007, 1:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •