Results 1 to 5 of 5

Thread: Webstorm plugin creates file in wrong encoding

  1. #1
    Sencha User
    Join Date
    Jun 2014
    Location
    Murmansk, Russia
    Posts
    284
    Answers
    3

    Default Answered: Webstorm plugin creates file in wrong encoding

    If use plugin option Create ExtJs class then file created in non-UTF-8. Have to convert it to UTF-8 manully.

  2. Sorry, my mistake. Webstorm has wrong project encoding setting.

  3. #2
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Is anyone else experiencing this behavior? It always creates UTF-8 files on my system.

  4. #3
    Sencha User
    Join Date
    Jun 2014
    Location
    Murmansk, Russia
    Posts
    284
    Answers
    3

    Default

    Sorry, my mistake. Webstorm has wrong project encoding setting.

  5. #4
    Sencha - Dev Team Chris.OBrien's Avatar
    Join Date
    Mar 2015
    Posts
    147
    Answers
    51

    Default

    I think this might be the behavior of JetBrains IDEs in general.

    When I create either a new ExtJS class with the plugin, or a HTML file with IntelliJ's built-in functionality, both files say they are UTF-8 at the bottom right of the IDE window. However, if i use file -I fileName.ext in my OSX terminal, they both say they are us-ascii.

    When I add an accented character, like a or , the IDE display remains the same, but the file -I command in OSX now returns UTF-8.

    What format are you first seeing the file when a new Ext JS class is created?

  6. #5
    Sencha User
    Join Date
    Jun 2014
    Location
    Murmansk, Russia
    Posts
    284
    Answers
    3

    Default

    Quote Originally Posted by Chris.OBrien View Post
    What format are you first seeing the file when a new Ext JS class is created?
    Now UTF-8 after I adjusted WebStorm settings.

Similar Threads

  1. [FIXED] Webstorm plugin does not recognize views
    By nikolay.bobrovskiy in forum JetBrains IDE Plugin
    Replies: 3
    Last Post: 18 May 2015, 7:08 AM
  2. [FIXED] IDE plugin for Webstorm (on Windows) freezing at startup
    By FBNitro in forum JetBrains IDE Plugin
    Replies: 5
    Last Post: 30 Apr 2015, 6:38 AM
  3. [FIXED] Plugin in WebStorm produces errors
    By [email protected] in forum JetBrains IDE Plugin
    Replies: 2
    Last Post: 15 Apr 2015, 5:29 AM
  4. Using Ext.Encoding in Android return wrong character encoding
    By korka in forum Sencha Touch 1.x: Bugs
    Replies: 2
    Last Post: 13 Dec 2011, 10:53 PM
  5. [OPEN] File upload gives wrong file names. Characters encoding issue?
    By ecanraf in forum Ext 3.x: Bugs
    Replies: 2
    Last Post: 18 Feb 2011, 4:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •