Results 1 to 6 of 6

Thread: CheckBox Disappears in Ext 6.0.0.415 beta

  1. #1

    Default CheckBox Disappears in Ext 6.0.0.415 beta

    I have ported my app (ext version 5.1.1) to the version 6 and when I use the neptune, gray,crisp theme the checkboxes in the forms disappear. The label is ok just disappears the box frame. When I use the new triton theme the checkbox seems to appear normally.

  2. #2
    Sencha - Community Support Team jsakalos's Avatar
    Join Date
    Apr 2007
    Location
    Slovakia
    Posts
    27,664
    Answers
    512

    Default

    Have you built your app? Triton uses font icons, other themes use images. Images are copied to the destination only after sencha app build.Another reason could be that you use your custom theme that also needs porting.
    Jozef Sakalos, aka Saki

    Education, extensions and services for developers at new http://extjs.eu
    News: Grid MultiSearch Plugin, Grid MultiSort Plugin, Configuring ViewModel Hierarchy


  3. #3

    Default

    I don't use custom theme and I have built it without errors, still trying to find out why is this happening.

  4. #4
    Sencha - Community Support Team jsakalos's Avatar
    Join Date
    Apr 2007
    Location
    Slovakia
    Posts
    27,664
    Answers
    512

    Default

    See in the network tab if the app is trying to load checkbox images. The images should be loaded without 404 error.
    Jozef Sakalos, aka Saki

    Education, extensions and services for developers at new http://extjs.eu
    News: Grid MultiSearch Plugin, Grid MultiSort Plugin, Configuring ViewModel Hierarchy


  5. #5

    Default

    The images are loaded correctly, so is not this the problem.
    I checked it more carefully and I noticed in the element inspector of chrome, sencha adds to the checkbox style the:
    .x-hidden-clip{
    position: absolute!important
    clip: rect(0,0,0,0)
    }

    If I disable the "position: absolute!important" then the checkbox appears on the form. I don't have any special property on the checkbox field that can explain this.
    Looks like a bug of the version 6. I don't know yet if i can use one specific property on the checkbox in order to fool the compiler and not to produce this style.

  6. #6
    Sencha Premium User
    Join Date
    Oct 2013
    Posts
    17

    Default Same problem

    I am having the same problem in version 6.0.1.250. Were you able to track down the problem?

Similar Threads

  1. Replies: 5
    Last Post: 12 Jan 2013, 10:45 PM
  2. [FIXED] 4.1 Beta 3 - Checkbox Focus Class Malformed
    By Macy Abbey in forum Ext:Bugs
    Replies: 1
    Last Post: 20 Mar 2012, 9:56 AM
  3. Replies: 15
    Last Post: 12 Mar 2012, 3:40 PM
  4. Replies: 1
    Last Post: 3 Jan 2012, 10:47 AM
  5. Beta to RC1 - checkbox.setValue() behavior change
    By Troy Wolf in forum Ext 2.x: Help & Discussion
    Replies: 0
    Last Post: 8 Nov 2007, 8:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •