Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: “Permission Denied” error in IE when it enters failure block (Fileuploadfield)

  1. #11
    Sencha User
    Join Date
    Aug 2015
    Location
    India
    Posts
    24

    Default

    Quote Originally Posted by Tim Toady View Post
    Looks like I hit your same issue a year later and this is the only thread I see on it. Sorry I didn't dig deeper. The real issue that is happening is actually an IE "feature" which we can get around. Long story short, IE blows away your response and uses its own error. It is an entirely back-end fix. All that is needed to fix this problem to prevent this from happening is
    1: Don't send success flag so that it hits your failure callback
    2. Pad the response length to at least 512 bytes. I just added another property on my response json for this I called "paddingForIE"

    Here is Microsoft's page to describe what its doing:
    https://blogs.msdn.microsoft.com/iei...p-error-pages/

    I realize you may have solved this or worked around this by now, but I wanted to update this post to have the answer so people who run into it in the future have a solution

    Thanks for your solution Tim.
    I have a workaround for this. I am handling failure condition in success block. To brief out, I am sending a flag from back-end to indicate it's a failure condition with success flag as 200.
    Here, I am not using failure block at all. I have handled both success and failure conditions in success block itself.
    Thanks!

  2. #12
    Sencha Premium Member
    Join Date
    Jan 2010
    Location
    Vancouver, Canada
    Posts
    256
    Answers
    4

    Default

    I came across the same issue in Ext Js 6.5.2.

    It all started because in IE 11, in compatibility view, returning json data from the server on form file uploads will prompt the user to save the json payload returned by the server. From this point on it was a rabbit hole. I tried to force IE to turn off the compatibility view by using:

    <clear />
    <add name="X-UA-Compatible" value="IE=edge" />

    in web.config. Sending this setting in the http headers didn't make any difference.

    To fix it - I am using Asp.Net Web Api - I had to return my json data as plain text, i.e. contentType = text/plain. However, in case of back-end exceptions, firstly I attempted to return a 500 error with the json object as plain text. But on the ext js side the following statement:

    doc = me.getDoc();

    in the onComplete function of Ext.data.request.Form failed with Permission Denied in IE with compatibility view on.

    As Nandu did, the solution was to return a 200 http status code but with with a json object that had a property success = false. Ext Js funneled the call to the form failure method and I handled the error message properly.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 11
    Last Post: 15 Mar 2019, 11:47 PM
  2. Replies: 0
    Last Post: 21 May 2010, 3:57 AM
  3. Permission denied error for HTML editor
    By nikhilkrishnan in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 1 Apr 2009, 4:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •