Results 1 to 5 of 5

Thread: Glibc 2.15 and 2.14 required on Linux

    You found a bug! We've classified it as ECP-99 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium User
    Join Date
    Jun 2012
    Posts
    48
    Answers
    1

    Default Answered: Glibc 2.15 and 2.14 required on Linux

    I received error messages when trying to create a new Sencha Project app and adding a Sencha Nature to an existing Dynamic Web Project. Both indicated glibc 2.15 and 2.14 was required. System is Oracle Linux 6.7 x64.

    It would be more helpful if the dependency check could be performed during the plugin installation.

    Here's the error message:
    Code:
    Tern process ended unexpectedly with exit code 1 on port 51315 for /home/XXX/workspace/SenchaTest
    
    Sencha Ext JS autocompletion will be disabled
    /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)
    /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)

  2. Quote Originally Posted by bartyhoho View Post
    I have 2.12.
    From my understanding, there was a large jump between 2.13 and 2.14. 2.12 was released in 2010, so it's unfortunate that even you're on a relatively new version of Oracle Linux, it's got an old glibc.

    I'm not sure if we'll be able to easily support older versions of glibc, but I'll create a ticket to track this issue for future evaluation.

    In the meantime, are you able to run on a different machine to evaluate, or potentially run VirtualBox with a different linux distro, like Ubuntu?

  3. #2
    Sencha - Dev Team Chris.OBrien's Avatar
    Join Date
    Mar 2015
    Posts
    147
    Answers
    51

    Default

    Quote Originally Posted by bartyhoho View Post
    I received error messages when trying to create a new Sencha Project app and adding a Sencha Nature to an existing Dynamic Web Project. Both indicated glibc 2.15 and 2.14 was required. System is Oracle Linux 6.7 x64.

    It would be more helpful if the dependency check could be performed during the plugin installation.

    Here's the error message:
    Code:
    Tern process ended unexpectedly with exit code 1 on port 51315 for /home/XXX/workspace/SenchaTest
    
    Sencha Ext JS autocompletion will be disabled
    /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)
    /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)
    From http://www.oracle.com/us/technologie...ons/index.html it looks like Oracle Linux 6.5 has glibc 2.11, so I'm assuming 6.7 has somewhere between 2.11 and 2.13.

    Can you run the following command in the command line, which will display what glibc version you have?

    Code:
    ldd --version
    Our plugin install can't check for the glibc version, since this is a background process launched separately from the plugin. It's compiled for each OS, but must have been compiled with a newer version of glibc.

  4. #3
    Sencha Premium User
    Join Date
    Jun 2012
    Posts
    48
    Answers
    1

    Default

    I have 2.12.

  5. #4
    Sencha - Dev Team Chris.OBrien's Avatar
    Join Date
    Mar 2015
    Posts
    147
    Answers
    51

    Default

    Quote Originally Posted by bartyhoho View Post
    I have 2.12.
    From my understanding, there was a large jump between 2.13 and 2.14. 2.12 was released in 2010, so it's unfortunate that even you're on a relatively new version of Oracle Linux, it's got an old glibc.

    I'm not sure if we'll be able to easily support older versions of glibc, but I'll create a ticket to track this issue for future evaluation.

    In the meantime, are you able to run on a different machine to evaluate, or potentially run VirtualBox with a different linux distro, like Ubuntu?

  6. #5
    Sencha Premium User
    Join Date
    Jun 2012
    Posts
    48
    Answers
    1

    Default

    Yeah, I was afraid of that. I am running on a VM, so I can try playing around to see what happens. I'll post with results if I get something working.

Similar Threads

  1. Replies: 5
    Last Post: 1 Aug 2017, 2:57 PM
  2. GLIBC not found error on Linux
    By jefftalley in forum Sencha Cmd
    Replies: 5
    Last Post: 17 Sep 2012, 3:32 PM
  3. Can you change "This field is required" text on a required TextField?
    By Syed Huda in forum Ext 3.x: Help & Discussion
    Replies: 1
    Last Post: 27 Jan 2011, 1:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •