Results 1 to 6 of 6

Thread: BUG: Sencha Cmd : Fonts missing when using -destination flag

    Success! Looks like we've fixed this one. According to our records the fix was applied for SDKTOOLS-1631 in 6.2.1.29.
  1. #1

    Default BUG: Sencha Cmd : Fonts missing when using -destination flag

    Sencha ExtJS version: 6.0.1
    Sencha Cmd version: 6.0.1.76
    Operation system: Windows 7 64 bit

    Problem
    Font-awesome and fonts folder are missing when specifying destination folder with the -destination flag . The font folders are still copied to the the app\s build folder.

    Generate app
    SenchaCmdGenerateApp.jpg

    Build app with -destination flag
    SenchaCmdAppBuild.png

    Observe that font-awesome and fonts folders are located in the default build folder.
    FontsInBuildFolder.png

    Observe that font-awesome and fonts folders are missing in the destination folder
    FontsMissingInDestinationFolder.jpg

    Observe that the app is not working
    FontsMissingInBrowser.png

    Workaround

    Edit your app.json and change resource settings.

    Code:
     "output": {
            "base": "${workspace.build.dir}/${build.environment}/${app.name}",
            "page": "index.html",
            "manifest": "${build.id}.json",
            "js": "${build.id}/app.js",
            "appCache": {
                "enable": false
            },
            "resources": {
                //"path": "${build.id}/resources", Replaced with next line as part of workaround.
                "path": "resources",
                "shared": "resources"
            }
        },
    Remove resource paths in
    ext/packages/font-awesome/packages.json
    /ext/classic/theme-triton/package.json

    Code:
    {
        "namespace": "Ext",
    
        "name": "font-awesome",
        "type": "code",
    
        "framework": "ext",
        "toolkit": "classic",
        "theme": "theme-neptune",
        //"requires": [
        //    ...
        //],
    
        "creator": "Sencha",
        "summary": "Package wrapper for Font Awesome",
        "detailedDescription": "Sencha Cmd package wrapper for Font Awesome (http://fortawesome.github.io/Font-Awesome/)",
    
        "version": "6.0.1.250",
        "compatVersion": "4.3.0",
        "format": "1",
    
        "output": "${framework.dir}/build/packages/${package.name}",
        "local": true,
    
       /* "resource": {
            "paths": ""
        },
    
        "resources": [
            {
                "path": "${package.dir}/resources",
                "output": "shared"
            }
        ],*/
    
        "sass": {
            "namespace": "Ext",
    
            "etc": "${package.dir}/sass/etc/all.scss",
    
            "var": "${package.dir}/sass/var",
    
            "src": [
                "${package.dir}/sass/src",
                "${package.dir}/sass/src/all.scss"
            ]
        },
    
        "classpath": "${package.dir}/src",
    
        "overrides": "${package.dir}/overrides",
    
        "slicer": null
    }
    This will ofcourse break the modern/classic approach but will work for classic

  2. #2
    Sencha Premium User
    Join Date
    Jan 2010
    Posts
    62

    Default

    Has this been accepted as a bug? I am experiencing the same thing.

  3. #3
    Sencha Premium User AussieFlem's Avatar
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Posts
    35

    Default

    I'm also seeing this on Mac OS X

  4. #4
    Sencha User
    Join Date
    Jul 2016
    Posts
    3

    Default Solution?

    I'm experiencing this as well and don't want to edit the Triton theme files directly.

  5. #5
    Sencha Premium Member
    Join Date
    Sep 2012
    Location
    Tokyo
    Posts
    13

    Default

    When will this bug be fixed?

  6. #6
    Sencha - Engineering israelroldan's Avatar
    Join Date
    Nov 2011
    Location
    The Netherlands
    Posts
    395

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

Similar Threads

  1. Replies: 2
    Last Post: 29 Oct 2013, 7:02 AM
  2. Missing fonts in Firefox and IE
    By brocktopia in forum Community Discussion
    Replies: 4
    Last Post: 8 Jul 2011, 3:27 PM
  3. Missing Flag resources on wiki
    By Frank in forum Community Discussion
    Replies: 13
    Last Post: 14 May 2008, 5:43 PM
  4. Missing fonts generic family name in ext-all.css
    By fermo111 in forum Ext 1.x: Bugs
    Replies: 0
    Last Post: 3 Aug 2007, 1:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •