Results 1 to 2 of 2

Thread: Load mask not displaying on grid with bound store

    This duplicates another forum thread, you can visit that thread here.
  1. #1
    Sencha User
    Join Date
    Nov 2015
    Posts
    1

    Default Load mask not displaying on grid with bound store

    [ExtJS-6.0.1.250] LoadMask missing on grids with bound store


    • Ext 6.0.1.250
    Browser versions tested against:
    • Chrome 46
    DOCTYPE tested against:
    • Strict
    Description:
    • When using a bound store with a grid the load mask does not show while the store is loading at first time
    Steps to reproduce the problem:
    • Create a grid with a bound store
    • Load the store
    Code:
    Ext.define('Fiddle.ViewModel', {
        extend: 'Ext.app.ViewModel',
        alias: 'viewmodel.test',
    
    
        stores: {
            myStore: {
                model: 'Fiddle.Model',
                autoLoad: true
            }
        }
    });
    
    
    Ext.define('Fiddle.ViewController', {
        extend: 'Ext.app.ViewController',
        alias: 'controller.test',
    
    
        refresh: function () {
            this.getViewModel().get('myStore').reload();
        }
    });
    
    
    Ext.define('Fiddle.View', {
        extend: 'Ext.grid.Panel',
        title: 'Load mask missing on grids with bound store',
    
    
        controller: 'test',
        
    
    
        viewModel: {
            type: 'test'
        },
    
    
        bind: {
            store: '{myStore}'
        },
    
    
        tbar: [{
            text: 'Refresh',
            handler: 'refresh'
        }],
    
    
        loadMask: true,
        
        viewConfig: {
            loadMask: true,
            loadingHeight: 100
            
        },
    
    
        columns: [{
            dataIndex: 'id',
            text: 'ID'
        }, {
            flex: 1,
            dataIndex: 'label',
            text: 'Label'
        }]
    });

    The result that was expected:
    • See the load mask while first load and every loads
    The result that occurs instead:
    • No loadmask
    Same issuse: https://www.sencha.com/forum/showthread.php?299670

    Fiddle: https://fiddle.sencha.com/#fiddle/111k




  2. #2
    Sencha User joel.watson's Avatar
    Join Date
    Nov 2014
    Posts
    3,120

    Default

    Thanks for the report, I've linked it to the previous report.

    Joel

Similar Threads

  1. Replies: 7
    Last Post: 12 May 2016, 5:00 PM
  2. Extjs 4.2.1 load mask not displaying properly
    By Sawan Samal in forum Ext: Q&A
    Replies: 1
    Last Post: 14 Oct 2014, 11:18 PM
  3. Replies: 1
    Last Post: 18 Feb 2014, 6:49 AM
  4. Replies: 5
    Last Post: 20 Apr 2011, 4:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •