Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Please do not upgrade to IntelliJ 15.0.2, WebStorm 11.0.2, etc...

  1. #1
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default Answered: Please do not upgrade to IntelliJ 15.0.2, WebStorm 11.0.2, etc...

    It looks like JetBrains made a breaking API change in their most recent minor release of their IDEs that causes errors during indexing. We are working on a fix. We will post an update here once it is fixed.

  2. Version 6.0.7 of the plugin has been released to address this issue: https://www.sencha.com/forum/showthr...-Now-Available!

  3. #2
    Sencha Premium Member
    Join Date
    Jan 2008
    Location
    Atlanta, GA
    Posts
    28

    Default

    Thanks for the update. Fortunately, I was able to downgrade back to 11.0.1 as I didn't see this before updating.

  4. #3
    Sencha Premium User AussieFlem's Avatar
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Posts
    35

    Default

    Are there any nightlies for the plugins?

  5. #4
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Sorry, there aren't. It shouldn't be too long now. I've solved all of the main issues related to API changes. Just need to work through my unit tests. We are hoping to get a new version out before Christmas.

  6. #5
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    Just wanted to give everyone an update on this. It was a little more tricky than I expected to fix the issues related to IntelliJ 15.0.2. We weren't able to get a new release ready for Christmas as I had hoped. We do, however, have all of the issues fixed in development now, so I think we should be able to release in the first week of the new year. Thank you everyone for your patience. Happy Holidays!

  7. #6
    Sencha User Stormseeker's Avatar
    Join Date
    Jan 2010
    Location
    Evanston, Illinois
    Posts
    59
    Answers
    3

    Default

    Hopefully they didn't break anything else with this update.

    http://blog.jetbrains.com/webstorm/2...bstorm-11-0-3/

  8. #7
    Sencha Premium User AussieFlem's Avatar
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Posts
    35

    Default Any news?

    Hi Mark.

    What news of the plugin update?

  9. #8
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114

    Default

    An update to address the breaking changes in 15.0.3 should be out by the end of the week. In addition, our testing shows that this update (v6.0.7) works with both IntelliJ 15.0.3 EAP and 16 EAP as well.

  10. #9
    Sencha Premium User AussieFlem's Avatar
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Posts
    35

    Default

    And WebStorm 11.0.3 ?


  11. #10
    Sencha Premium Member
    Join Date
    Feb 2012
    Posts
    40
    Answers
    2

    Default

    Sencha, you're so lame...

Page 1 of 2 12 LastLast

Similar Threads

  1. Issues with IntelliJ 15, WebStorm 11, PhpStorm 10
    By Mark.Brocato in forum JetBrains IDE Plugin
    Replies: 2
    Last Post: 13 Nov 2015, 5:41 AM
  2. IntelliJ Plugin Locks Up Intellij
    By jmcolyer in forum JetBrains IDE Plugin
    Replies: 12
    Last Post: 27 May 2015, 6:54 AM
  3. ExtJS 5, Sencha Cmd, IntelliJ
    By jb44 in forum Ext 5: Q&A
    Replies: 1
    Last Post: 3 Sep 2014, 4:33 PM
  4. Please help with debugging in IntelliJ
    By denisputnam in forum Ext: Q&A
    Replies: 5
    Last Post: 26 Feb 2013, 1:29 PM
  5. Gxt Beta 4 & IntelliJ
    By michaelosity in forum Community Discussion
    Replies: 3
    Last Post: 8 Dec 2008, 7:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •