Results 1 to 3 of 3

Thread: XTemplate in non visibible tab does not render when using binding on Component.data

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Jun 2008
    Posts
    242

    Default XTemplate in non visibible tab does not render when using binding on Component.data

    See that the XTemplate is not being rendered for "tab two". "tab one" works correctly.


  2. #2
    Sencha - Sustaining Engineer tristan.lee's Avatar
    Join Date
    Mar 2015
    Location
    Central Ohio
    Posts
    1,579

    Default

    Check your second item in the tab panel. The config is mis-typed as xype instead of xtype.
    Tristan Lee
    Sencha Inc - Sustaining Engineer


    Having an issue? Help us help you - be detailed; provide some code; demonstrate with a fiddle (fiddle.sencha.com)

    Embed your fiddle in your post: [FIDDLE]id[/FIDDLE]

  3. #3
    Sencha User
    Join Date
    Jun 2008
    Posts
    242

    Default

    Got it. I've updated the fliddle to better reflect the situation I'm seeing. Notice that the bindings are not reflected in the second tab?

Similar Threads

  1. Custom Component Data Binding
    By Maxime L-V in forum Ext 5: Q&A
    Replies: 2
    Last Post: 27 Aug 2014, 10:22 AM
  2. Replies: 1
    Last Post: 20 Apr 2012, 8:33 AM
  3. XTemplate Automatic Data Update/Binding?
    By brian428 in forum Community Discussion
    Replies: 2
    Last Post: 1 Mar 2012, 1:56 AM
  4. formpanel + xtemplate +jsonstore not binding data
    By elona in forum Ext 2.x: Help & Discussion
    Replies: 0
    Last Post: 7 Jul 2009, 11:36 PM
  5. Data Binding on non-datagrid component
    By damnos in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 16 Mar 2009, 12:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •