Results 1 to 3 of 3

Thread: Ext 6.0.2.437 / Cmd 6.1.1.76 Running Dev / Single File Mode Failing

  1. #1

    Join Date
    Sep 2010
    Location
    Nashville, TN
    Posts
    58

    Default Ext 6.0.2.437 / Cmd 6.1.1.76 Running Dev / Single File Mode Failing

    Running on Ext 6.0.1.250 / Cmd 6.0.2.14 running with the build framework commented out (see below) would allow the app to run in a debug mode (all individual Ext classes available as individual files). After the upgrade to 6.0.2, this is broken where all of the individual files do appear to load, however the Ext.env.Ready.onReadyEvent is never fired, and thus the app never launches. Not sure if this is due to our implementation, an Ext JS bug, or Cmd bug. I was able to reproduce it using a nightly Cmd 6.1.2.15 as well. Is anyone else seeing this after the upgrade(s)? Thanks.

    Code:
    /**
     * Settings specific to classic toolkit builds.
     */
    "classic": {
        "js": [
            // Remove this entry to individually load sources from the framework.
           // {
           //     "path": "${framework.dir}/build/ext-all-rtl-debug.js"
          //  }
    ]
    },

  2. #2
    Sencha User joel.watson's Avatar
    Join Date
    Nov 2014
    Posts
    3,120
    Answers
    446

    Default

    Hi--

    Is this issue still occurring in the latest version of Sencha Cmd?

    Thanks!
    Joel

  3. #3
    Sencha User
    Join Date
    Apr 2013
    Posts
    147
    Answers
    5

    Default

    I am using sencha cmd (v6.1.2.15) to create a extjs (v6.0.2) modern app, but it cannot run on an android 4.2 (maybe all android under 4.4) stock browser after I build production(or testing).

    What's weird is that a extjs6 modern app without sencha cmd(a html file + 'ext-modern-all.js' + 'theme-triton-all.css') works like a charm on android 4.2.

Similar Threads

  1. Error when running in sandbox mode
    By UserSenchasen in forum Ext: Q&A
    Replies: 3
    Last Post: 9 Jan 2014, 2:17 PM
  2. Replies: 2
    Last Post: 18 Dec 2013, 1:03 PM
  3. Replies: 1
    Last Post: 17 Oct 2011, 11:04 PM
  4. error running in hosted mode
    By reecegwt in forum Ext GWT: Discussion
    Replies: 2
    Last Post: 1 Apr 2010, 12:02 AM
  5. Running GXT EXT Examples in Host Mode
    By ExtJsNoviceMember in forum Ext GWT: Help & Discussion (1.x)
    Replies: 3
    Last Post: 6 Jan 2009, 9:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •