Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 6.1.2.15: How to disable PhantomJS?

    You found a bug! We've classified it as SDKTOOLS-1447 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium Member
    Join Date
    Mar 2015
    Location
    Raleigh, NC
    Posts
    47

    Question 6.1.2.15: How to disable PhantomJS?

    Just upgraded to Sencha CMD 6.1.2.15 and Extjs 6.0.2.
    Building fine on a Windows box, but moved to older Linux install and 'sencha app watch' is dying on PhantomJS.

    I don't need to support older versions of IE so I don't need the slicer stuff, but even with adding -- "slicer":null to the app.json file, I'm getting the following error dump:

    Code:
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExBuild: PhantomJS sass build exited with code : 1
    [ERR]   at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
    [ERR]
    [ERR] Total time: 10 seconds
    [ERR] The following error occurred while executing this line:
    /app/.sencha/app/build-impl.xml:247: The following error occurred while executing this line:
    /app/.sencha/app/watch-impl.xml:61: The following error occurred while executing this line:
    /app/.sencha/app/build-impl.xml:285: The following error occurred while executing this line:
    /app/.sencha/app/sass-impl.xml:189: The following error occurred while executing this line:
    /app/.sencha/app/sass-impl.xml:212: com.sencha.exceptions.ExBuild: PhantomJS sass build exited with code : 1
    I had no problems with the CMD version that supported 6.0.1. What could be the issue?
    Are their other settings I can apply to my app.json file to turn off phantomJS all together?

  2. #2
    Sencha Premium Member
    Join Date
    May 2011
    Posts
    66

    Default

    I am also having a similar experience with 6.1.2.15. On my Windows 7 machine, I get the following when I run sencha app build:

    Code:
    [ERR] 
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExBuild: PhantomJS sass build exited with code : -1073741819
    [ERR] 	at sun.reflect.Del
    [ERR] egatingMethodAccessorImpl.invoke(Unknown Source)
    [ERR] 
    [ERR] Total time: 14 seconds
    [ERR] The following error occurred while executing this line:
    I also tried disabling the slicer as suggested in the thread below, but it doesn't help. A colleague got 6.1.2.15 and it works just fine on his Windows machine with identical specs.

    https://www.sencha.com/forum/showthread.php?298627

  3. #3
    Sencha Premium Member
    Join Date
    Mar 2015
    Location
    Raleigh, NC
    Posts
    47

    Lightbulb

    I know it's a NO NO, but I commented out the lines causing problems in the sass-impl.xml file.

    Code:
     <!-- <x-sencha-command>
    213                                 fashion
    214                                     -compress=${build.css.compress}
    215                                     -split=${build.css.selector.limit}
    216                                     -saveFile=${app.dir}/${app.sass.save}
    217                                     ${app.out.scss}
    218                                     ${app.out.css}
    219                             </x-sencha-command> -->
    Maybe this will lead someone to suggest a better fix for me?

    UPDATE: Commenting out the above leaves me with a TEMP File (<project-name>-all.scss.tmp) that never gets converted to <project-name>-all.scss. So this isn't really a good solution. :/ But at least 'sencha app watch' completes.

  4. #4
    Sencha Premium Member
    Join Date
    Mar 2015
    Location
    Raleigh, NC
    Posts
    47

    Default

    Not sure where bugs are tracked, but support has given me this reference to a bug ticket that was opened: SDKTOOLS-1447

    Anyone know how to track its status?

  5. #5
    Sencha Premium Member
    Join Date
    Jan 2015
    Location
    Austria
    Posts
    6

    Default

    Hello,

    we also had an issue running phantomJS from sencha cmd on RHEL5.
    We figured out that phantomJS required C/C++ libs that have not been available on RHEL5.

    So we took the latest required C/C++ libs from RHEL6 and call phantomJS with a custom script.Therefore we renamed the phantomjs executable in the sencha cmd directory to phantomjs.bin and created a script called phantomjs.
    So sencha cmd calls our script.

    The script's content is the following:
    export BINARY_PATH=/sencha_cmd_6/Cmd/6.1.1.76/bin/linux-x64/phantomjs
    export LIBRARY_PATH=$BINARY_PATH/RHEL6
    env LD_LIBRARY_PATH=$LIBRARY_PATH $LIBRARY_PATH/ld-linux-x86-64.so.2 $BINARY_PATH/phantomjs.bin "[email protected]"

    The required libs are documented at the phantomjs download page:The system must have GLIBCXX_3.4.9 and GLIBC_2.7.

    Regards

  6. #6
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    sirwesley, you can check the ticket progress in the Support portal using the linked bug ticket link at the bottom of the ticket details panel. I've also linked this forum thread with the ticket, so some information can be found at the top of this thread, and it will update with the bug ticket.

  7. #7
    Sencha Premium Member
    Join Date
    Mar 2014
    Posts
    63

    Default

    Any news on this? My build is hanging on PhantomJS and there is not even any way to just stop using the slicer. It's a very important bug for us.

  8. #8
    Sencha Premium User
    Join Date
    Dec 2007
    Location
    Netherlands
    Posts
    43

    Default

    Also get this error with Sencha Cmd version 6.1.3.42 on Windows 7 (32bit and 64bit), any news on this?

  9. #9

    Default Same problem..+ workaround (downgrade phantomjs)

    Quote Originally Posted by seg View Post
    Also get this error with Sencha Cmd version 6.1.3.42 on Windows 7 (32bit and 64bit), any news on this?
    I have the same problem since som software update on my Windows 7 machine.

    The problem is that phantomjs.exe is just hanging or taking like 5 minutes to execute.

    You can try this by going into the sencha/cmd/6.1.3.42/bin/windows/phantomjs folder and execute phantomjs.exe. You should ge a prompt but it doesnt happen.

    I had to copy an older phantomjs.exe into this folder. I took mine from my Sencha cmd version 6.0.1.76 folder.

    Key is that phantomjs.exe version 1.9.2 works fine but phantomjs.exe version 2.1.1.0 hangs.

  10. #10

    Default

    Same issue with me. I'm not able to build too. Following is the build failure error:

    Code:
    [exec] Fatal Windows exception, code 0xc0000005.[exec] PhantomJS has crashed. Please read the bug reporting guide at
    [exec] <http://phantomjs.org/bug-reporting.html> and file a bug report.
    [exec] [ERR]
    [exec] [ERR] BUILD FAILED
    [exec] [ERR] com.sencha.exceptions.ExBuild: PhantomJS sass build exited with code : -1073741819
    [exec] [ERR]       at sun.reflect.Del
    [exec] [ERR] egatingMethodAccessorImpl.invoke(Unknown Source)

Page 1 of 2 12 LastLast

Similar Threads

  1. PhantomJS crashing on amzn1
    By hurdad in forum Sencha Cmd
    Replies: 1
    Last Post: 21 Jul 2015, 5:51 AM
  2. Why does Fashion require PhantomJS?
    By GSandoval-Greentree in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 21 Apr 2015, 2:19 AM
  3. How to use extjs with phantomjs?
    By usavahe in forum Ext: Q&A
    Replies: 1
    Last Post: 16 May 2014, 3:03 PM
  4. Replies: 4
    Last Post: 14 Aug 2013, 5:01 PM
  5. PhantomJS selenium tests?
    By stefankendall in forum Sencha Touch 2.x: Discussion
    Replies: 6
    Last Post: 24 Jan 2013, 11:23 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •