Results 1 to 10 of 10

Thread: Extensible calendar and extjs6

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Answered: Extensible calendar and extjs6

    Hi guys,
    I'm trying to integrate the calendar example into my app, but i'm stuck at the moment. what i have tried until now is:
    • create a new package: sencha generate package -type code calendar
    • paste the code from calendar example
    • sencha build package
    But the build failed!
    Is there any docs that can point me in the right direction?
    Thx,
    M

  2. You should still add it in app.json but in "classic" section:
    Code:
    /**
     * Settings specific to classic toolkit builds.
     */
    "classic": {
        "js": [
            // Remove this entry to individually load sources from the framework.
            {
                "path": "${framework.dir}/build/ext-all-rtl-debug.js"
            }
        ],
        "requires": [
            "font-awesome",
            "locale",
            "saki-field-icon",
            "ux"
        ]
    }

  3. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    There are Getting Started instructions in this readme file from the github for the Extensible Calendar project:
    https://github.com/bmoeskau/Extensib...ster/README.md

  4. #3

    Default

    Quote Originally Posted by Gary Schlosberg View Post
    There are Getting Started instructions in this readme file from the github for the Extensible Calendar project:
    https://github.com/bmoeskau/Extensib...ster/README.md
    I read the documentation, but i couldn't fully understand. So if you can provide a few hints on how to start, it would be much aprecitated.
    Thank you,
    M

  5. #4
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    I haven't used the Extensible calendar myself, but hopefully someone here has some experience and can throw out some suggestions. You might try posting a thread on the Extensible forums as well.
    http://ext.ensible.com/forum/

  6. #5
    Sencha User
    Join Date
    Apr 2013
    Posts
    914
    Answers
    105

    Default

    If you download the provided package for Ext 4, you can find a simple example in examples/calendar/basic.js . Is there something you don't understand in that example?

  7. #6

    Default

    After I created the package and added the code for extensible into the src, i tried a "sencha app refresh". The problem I'm facing now is linked to the dependencies. I'm getting this error now:
    Code:
    [ERR] Failed to resolve dependency Ext.dd.DragZone for file Extensible.calendar.dd.DragZone
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExNotFound: Unknown definition for dependency : Ext.dd.DragZone
    Any ideas?
    Thx,
    M

  8. #7
    Ext JS Premium Member
    Join Date
    Feb 2009
    Posts
    102
    Answers
    5

    Default

    Did you ever get the Extensible calendar to work with ExtJS 6?

  9. #8
    Sencha User
    Join Date
    Apr 2013
    Posts
    914
    Answers
    105

    Default

    Do you by any chance have universal app and added the package to the shared "requires" array? Ext.dd.DragZone is present in classic toolkit but not modern.

  10. #9

    Default

    Quote Originally Posted by hakimio View Post
    Do you by any chance have universal app and added the package to the shared "requires" array? Ext.dd.DragZone is present in classic toolkit but not modern.
    That is correct and you are right. Where should i add this requirement, if not in app.json? Or, how should I approach this?
    Thank you,
    Marius

    UPDATE:
    I've added the requirement in the specific toolkit:
    Code:
    "classic": {
            "js": [
    //            // Remove this entry to individually load sources from the framework.
    //            {
    //                "path": "${framework.dir}/build/ext-all-rtl-debug.js"
    //            }
            ],
            "requires": ["calendar"]
        },
    and the "sencha app refresh" seems to work. I'll check if the dependencies are loaded properly.
    Thanks,
    M

  11. #10
    Sencha User
    Join Date
    Apr 2013
    Posts
    914
    Answers
    105

    Default

    You should still add it in app.json but in "classic" section:
    Code:
    /**
     * Settings specific to classic toolkit builds.
     */
    "classic": {
        "js": [
            // Remove this entry to individually load sources from the framework.
            {
                "path": "${framework.dir}/build/ext-all-rtl-debug.js"
            }
        ],
        "requires": [
            "font-awesome",
            "locale",
            "saki-field-icon",
            "ux"
        ]
    }

Similar Threads

  1. ExtJs Extensible calendar
    By faradox in forum Ext: Q&A
    Replies: 1
    Last Post: 10 Feb 2016, 8:25 AM
  2. extensible-1.5.2 calendar customization
    By techleadz in forum Ext: Q&A
    Replies: 2
    Last Post: 25 Jul 2014, 8:56 AM
  3. Extensible.calendar.view.DayHeader in Calendar
    By Anfield in forum Ext: Discussion
    Replies: 1
    Last Post: 15 May 2014, 9:51 AM
  4. Extensible.calendar.view.DayHeader in Calendar
    By Anfield in forum Ext: Q&A
    Replies: 1
    Last Post: 15 May 2014, 8:53 AM
  5. Error in Calendar component (Extensible)
    By fabiojpoli in forum Ext 3.x: Bugs
    Replies: 0
    Last Post: 21 Jun 2011, 5:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •