Results 1 to 4 of 4

Thread: Font Awesome icons disappear if crisp theme is modified

    You found a bug! We've classified it as DSGNR-6968 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium User
    Join Date
    Dec 2013
    Posts
    10
    Vote Rating
    1
      0  

    Default Font Awesome icons disappear if crisp theme is modified

    REQUIRED INFORMATION

    Architect Build tested:
    • 3.5.1.348
    Project Type:
    • ExtJS 6.0.2
    Description:
    • As soon as I override a theme variable in the Crisp theme, for example $base-color, any font awesome icons that I have used on any buttons, panel headers etc disappear from the design view. If I compile the app and view it in the browser the icons show up fine, its only within architect itself that they disappear, and only if you modify the Crisp theme. With a clean unmodified theme they display fine.
    Steps to reproduce the problem:
    • Create a new project with a simple panel.
    • Assign an iconCls of "x-fa fa-home" to render a home icon in the header.
    • Add a button and assign that an iconCls of let's say "x-fa fa-trash". This should render a trash can icon.
    • Now go into the Crisp theme resource (MyCrispTheme) and change the $base-color.
    • After the theme has compiled, watch the icons disappear!
    The result that was expected:
    • Panel and button Colours should change to reflect new base theme colour
    • Icons should remain visible
    The result that occurs instead:
    • Colours change but icons disappear
    HELPFUL INFORMATION

    Screenshot, Project, or Video:
    Possible fix:
    • not provided
    Operating System:
    • Windows 10 Pro N 64-Bit

  2. #2
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795
    Vote Rating
    52
      0  

    Default

    Hi

    Thanks for the report. Does it also disappear from the app (preview in the browser) or just on the Canvas?

    Thank you
    Petr

  3. #3
    Sencha Premium User
    Join Date
    Dec 2013
    Posts
    10
    Vote Rating
    1
      0  

    Default

    Hi Petr,

    The icons show up fine in preview, and also in the compiled app. It's just on the Canvas within Architect that they disappear.

    Dave.

  4. #4
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795
    Vote Rating
    52
      0  

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

Similar Threads

  1. Font Icons (Pictos, Font Awesome) not available on Windows 8.1
    By garysybex1 in forum Sencha Touch 2.x: Bugs
    Replies: 0
    Last Post: 1 Jun 2016, 5:33 AM
  2. Firefox 21.0 Font Awesome Icons Problem
    By thro in forum Ext 6: Q&A
    Replies: 1
    Last Post: 5 Apr 2016, 11:33 AM
  3. Using Font Awesome icons for tab 'glyphs'
    By jhoweaa in forum Ext 6: Q&A
    Replies: 1
    Last Post: 26 Feb 2016, 2:16 PM
  4. Tree nodes with Font-Awesome icons
    By candycrate in forum Ext 6: Q&A
    Replies: 5
    Last Post: 7 Sep 2015, 6:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •