Results 1 to 5 of 5

Thread: stripeRows not working for empty cells

  1. #1
    Sencha User
    Join Date
    Jul 2010
    Posts
    46
    Answers
    3

    Default stripeRows not working for empty cells

    Grid has stripeRows: true in grid create and viewConfig of grid but when cells are null the stripe does not goo all the way across.
    grid.jpg

  2. #2
    Sencha User
    Join Date
    Jul 2010
    Posts
    46
    Answers
    3

    Default

    [QUOTE=mdarretta;1158353]Grid has stripeRows: true in grid create and viewConfig of grid but when cells are null the stripe does not goo all the way across.
    grid.jpg
    i added this code to renderer function and it works but i read this is a performance hit.

    store.each(function(record) {
    if (record.get("test") == null) {
    record.set('test',' ');
    }
    });

  3. #3
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    So it's not coloring if there's no data? Perhaps it would be less of a performance hit if you had those values originate in your data.

  4. #4
    Sencha User
    Join Date
    Jul 2010
    Posts
    46
    Answers
    3

    Default

    is this much of a performance hit? do you see any problem doing it this way?

    i could do it in java backend.

  5. #5
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    I suppose it depends on your project, especially the number of records involved. I personally would benchmark it on a slower machine to see if things still perform reasonably. Performing this on the server moves the processing from client, but the difference might be negligible.

Similar Threads

  1. StripeRows not working in Grid when there is RowExpander
    By quande.ren in forum Sencha GXT Bugs
    Replies: 3
    Last Post: 21 Apr 2015, 6:39 AM
  2. [NOREPRO] 5.1.1 Nightly: IE8 stripeRows not working
    By SebTardif in forum Ext 5: Bugs
    Replies: 3
    Last Post: 20 Dec 2014, 1:32 PM
  3. [Solved]stripeRows css not working
    By fallenrayne in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 13 Dec 2007, 2:14 PM
  4. [Ext 2.0 Revision 911] Grid stripeRows not working
    By ftftft in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 7 Sep 2007, 4:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •