Results 1 to 5 of 5

Thread: Tooltips not working

  1. #1
    Sencha User
    Join Date
    Aug 2016
    Posts
    14
    Answers
    1

    Default Answered: Tooltips not working

    Hi everybody! (sorry for my english)

    I'm creating an application and I don't know what I did, but I noticed that tooltips are not working (all of them...including tooltips that sencha shows automatically like grids, collapsing panel, etc.).

    Every time I pass the mouse over an item that should display a tooltip I get the following error on console:

    Code:
    app.js?_dc=1479521449412:66380 Uncaught TypeError: Cannot read property 'setAttribute' of null(…)
    onHide @ app.js?_dc=1479521449412:66380
    callParent @ app.js?_dc=1479521449412:10969
    onHide @ app.js?_dc=1479521449412:139886
    callParent @ app.js?_dc=1479521449412:10969
    onHide @ app.js?_dc=1479521449412:166906
    hide @ app.js?_dc=1479521449412:65727
    callParent @ app.js?_dc=1479521449412:10969
    hide @ app.js?_dc=1479521449412:166842
    callParent @ app.js?_dc=1479521449412:10969
    hide @ app.js?_dc=1479521449412:167351
    (anonymous function) @ app.js?_dc=1479521449412:5353
    (anonymous function) @ app.js?_dc=1479521449412:5543
    Anyone knows what is happening?


    Thanks in advance!

  2. Can you try to add the following code to your init method, to see if it helps:
    PHP Code:
    Ext.tip.QuickTipManager.init(); 
    If it doesn't, you can try a workaround mentioned in this bug report:
    PHP Code:
    var me this,
         
    ariaDom me.ariaEl && me.ariaEl.dom;

         if (!
    me.ariaStaticRoles[me.ariaRole] && ariaDom) {
            
    ariaDom.setAttribute('aria-hidden'false);
        } 

  3. #2
    Sencha User
    Join Date
    Aug 2016
    Posts
    14
    Answers
    1

    Default

    Looking at the debbugger, the dom from ariaEl on Component is null. Do I have to initialize it?


    Tooltip.jpg

  4. #3
    Sencha User
    Join Date
    Apr 2013
    Posts
    914
    Answers
    105

    Default

    Can you try to add the following code to your init method, to see if it helps:
    PHP Code:
    Ext.tip.QuickTipManager.init(); 
    If it doesn't, you can try a workaround mentioned in this bug report:
    PHP Code:
    var me this,
         
    ariaDom me.ariaEl && me.ariaEl.dom;

         if (!
    me.ariaStaticRoles[me.ariaRole] && ariaDom) {
            
    ariaDom.setAttribute('aria-hidden'false);
        } 

  5. #4
    Sencha User
    Join Date
    Aug 2016
    Posts
    14
    Answers
    1

    Default

    Thanks for your answer!

    Because of your answer I found out what was going on!
    I tried the first solution and my splashscreen stopped to work. Somehow, on fading it out, I was destroying the quicktips....

    The code that was causing the mess I got from the book Mastering Extjs (http://www.amazon.com/Mastering-ExtJ...tering+Extjs):

    Code:
    var splashscreen = Ext.getBody().mask('Loading..', 'splashscreen');
    
    splashscreen.next().fadeOut({
                duration: 1000,
                remove: true,
                listeners: {
                    afteranimate: function(el, startTime, eOpts) {
                        Ext.widget('login-dialog');
                    }
                }
            });
            
    
            var task = new Ext.util.DelayedTask(function() {
                    //Fade out the body mask
                    splashscreen.fadeOut({
                        duration: 500,
                        remove: true
                    });
                });
                
            task.delay(1000);

    Thanks!

  6. #5

    Join Date
    Aug 2007
    Location
    Romania
    Posts
    41

    Default

    Thanks guys. I had the same problem when upgrading an application from ext 4 to ext 6. You pointed me in the right direction. Thank you very much.

Similar Threads

  1. ExtJs 3.4; Tooltips not working on IE8
    By Quinnland23 in forum Ext 3.x: Help & Discussion
    Replies: 1
    Last Post: 13 Mar 2014, 11:02 AM
  2. [FIXED] Pie Chart - tooltips not working?
    By kenoyer130 in forum Sencha GXT Bugs
    Replies: 1
    Last Post: 6 Feb 2012, 4:14 PM
  3. Tooltips on labels not working
    By valfumble in forum Ext 3.x: Help & Discussion
    Replies: 1
    Last Post: 19 Jan 2011, 10:32 AM
  4. tooltips not working
    By valfumble in forum Ext 3.x: Help & Discussion
    Replies: 2
    Last Post: 7 Dec 2010, 11:35 AM
  5. Are anchored tooltips working in GXT 2.0 ?
    By Glimpse in forum Ext GWT: Discussion
    Replies: 4
    Last Post: 24 Aug 2009, 11:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •