Results 1 to 6 of 6

Thread: Plugin Failing Completely

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium Member
    Join Date
    Oct 2007
    Posts
    129
    Vote Rating
    3
      0  

    Default Plugin Failing Completely

    Hi All,

    The VSCode Sencha Plugin has complete stopped working for me.

    Here is my setup:

    Mac Version 10.11.6 (El Capitan)
    VSCode 1.8.1
    Sencha plugin: 1.0.1
    Sencha command 6.2.1.29
    ExtJs 6.2.1

    Yesterday I created a workspace and app using vscode and the sencha vscode plugin and all of the plugin items like intellisense, Goto Definition, Peek Definition, "sencha app watch" and so forth were working fine for the rest of the day.

    The VSCode plugin also handled my recently created ExtJS workspaces and apps just fine. These were created manually with Sencha Command outside of VSCode but the plugin was working fine yesterday.

    I came back to work this morning and nothing about the plugin works.

    Goto Definition and Peek Definition fail silently.
    F1 over an ExtJS class fails with: command 'extensions.vscode-extjs.goToDocs' not found

    These related failures also occur:
    command 'extension.vscode-extjs.createApp' not found
    command 'extension.vscode-extjs.createWorkspace' not found
    command 'extension.vscode-extjs.createPackage' not found
    command 'extension.vscode-extjs.showLogs' not found

    I uninstalled the plugin and removed VSCode by deleting these files/folders

    /Applications/Visual Studio Code.app
    /private/tmp/VSCode Crashes
    ~/.vscode
    ~/Library/Application Support/Code
    ~/Library/Caches/Code
    ~/Library/Preferences/com.microsoft.VSCode.*
    ~/Library/Saved Application State/com.microsoft.VSCode.savedState

    From this link: http://apple.stackexchange.com/quest...al-studio-code

    After I reinstalled VSCode and reinstalled the plugin, it is still failing as described above.

    Please help. I have come to rely on this tool doing what it is supposed to do and am trying to get other people to buy into it.

    What course of action can I take to get this setup correctly again?

    --Scott

  2. #2
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114
    Vote Rating
    53
      0  

    Default

    I've run into a few cases where Visual Studio Code does not properly clean up uninstalled plugins. On Mac OS I've fixed this by deleting the plugin from ~/.vscode/extensions and restarting Visual Studio Code. Once you've done that, try reinstalling the plugin. For what it's worth I've running the exact same setup here and everything is working fine.

  3. #3
    Sencha Premium Member
    Join Date
    Oct 2007
    Posts
    129
    Vote Rating
    3
      0  

    Default

    Hi Mark,

    Thanks for your reply.

    I did what you suggested and the failures noted in my original note are still occurring.

    In my first note I mentioned that I uninstalled everything related to VSCode, deleted related files, folders, etc. (see my first note for details) and that didn't correct it either.

    I'm at a loss and have no idea how to get this corrected.

    What else can you suggest?

    Is there a log file somewhere that could bring some clarity to this?

    Thanks,
    Scott

  4. #4
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114
    Vote Rating
    53
      0  

    Default

    The log file is at ~/Library/Application Support/Sencha/VSCode/vscode-extjs.log. Post the contents and I'll have a look. Failing that I'd be happy to get on a hangout with you to further troubleshoot.

  5. #5
    Sencha Premium Member
    Join Date
    Oct 2007
    Posts
    129
    Vote Rating
    3
      0  

    Default

    Hey Mark,

    Thanks for your reply! The log file is empty, strangely enough.

    I would love to get on a hangout or a gotomeeting to look at this further.

    --Scott

  6. #6
    Sencha User Mark.Brocato's Avatar
    Join Date
    Mar 2015
    Location
    Maryland
    Posts
    482
    Answers
    114
    Vote Rating
    53
      0  

    Default

    That must mean that it's not installing at all. I'll PM to set up a time.

Similar Threads

  1. Need help: I'm going completely mad
    By vizcano in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 19 Sep 2008, 5:23 AM
  2. How to completely skin Ext 2.0 ?
    By tfulmino in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 21 Aug 2008, 6:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •