Results 1 to 2 of 2

Thread: Highcharts, different versions in one Ext 4. Project

  1. #1

    Default Highcharts, different versions in one Ext 4. Project

    Hi,

    i´m working on a older project, written with EXT 4.1, using HighCharts 2* via UX.

    Now i have to integrate some functions were highChart 4.* is needed. (Gauges)

    So i wan´t to integrate both versions parallel.
    I am using the 2 UX´es from Joe Kuan
    If i using HighCharts OLD it works.
    If i using Highchart NEW it works
    If i try to integrate both Versions parallel, it doesn´t work.

    My Installation includes:
    lib/ux/Highchart.js (Old)
    lib/ux/Chart/Highchart.js (New)

    Both libarys are loaded via INDEX Page
    <script type="text/javascript" src=".....


    Is there a solution to work via
    HighartOLD = new HighchartsOldUX(...)

    HighchartNEW= new HighchartsNewUx(...)

    Any Idea ?

    BR
    Christian

  2. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985

    Default

    Sounds like the two versions are conflicting -- perhaps a namespace collision. What happens when it doesn't work? What is the problem with leaving the older version behind?

Similar Threads

  1. GPL Versions of previous versions
    By andreas-spindler in forum Ext 5: Q&A
    Replies: 0
    Last Post: 9 Oct 2015, 1:30 AM
  2. How to upgrade project files to newer framework versions?
    By cribellum in forum Sencha Architect 2.x: Help & Discussions
    Replies: 5
    Last Post: 28 Oct 2013, 11:47 AM
  3. Highcharts in Ext 4
    By KartoPete in forum Ext: Q&A
    Replies: 2
    Last Post: 25 Mar 2012, 6:29 AM
  4. extjs with highcharts
    By tony_tan in forum Ext 3.x: Help & Discussion
    Replies: 1
    Last Post: 20 Jan 2012, 4:48 AM
  5. How to use the highcharts?
    By fisherfu in forum Sencha Touch 1.x: Charts
    Replies: 6
    Last Post: 31 Aug 2011, 10:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •