Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Command must be run from a framework folder.

  1. #1
    Sencha User
    Join Date
    Sep 2009
    Location
    Colorado
    Posts
    11
    Answers
    1

    Default Answered: Command must be run from a framework folder.

    Hello,

    I am taking over an app that was started with a trial SDK (and have the ugly trial watermark to deal with). I have a commercial SDK and am trying to run sencha app upgrade /path/to/sdk on it but am getting the following error:

    Command must be run from a framework folder.

    What is a framework folder, I have run it in the ext, classic, modern and app folders and get the same error.

    So the question is FROM where should I run this command?

  2. The problem ended up being that the SDK I downloaded was corrupt. Once the new SDK was in place it all worked perfectly.

  3. #2
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    Normally you'd run that from the application folder. Do you by chance have a space in your path to SDK?

  4. #3
    Sencha User
    Join Date
    Sep 2009
    Location
    Colorado
    Posts
    11
    Answers
    1

    Default

    Gary,

    Thanks for your help. Here is the exact command I am running:

    sencha app upgrade "C:\Software\Sencha\SDK\ext-6.2.1"

    What am I missing?

  5. #4
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    That looks correct. Any different results without the double quotes?

  6. #5
    Sencha User
    Join Date
    Sep 2009
    Location
    Colorado
    Posts
    11
    Answers
    1

    Default

    Same behavior both ways.

  7. #6
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    The only way I've been able to recreate this error is if I point to an invalid framework directory. Can you double check your SDK path? Is this application within a workspace or generated outside of one?

  8. #7
    Sencha User
    Join Date
    Sep 2009
    Location
    Colorado
    Posts
    11
    Answers
    1

    Default

    Gary,

    I inherited this stubbed out app from a developer who has left the organization. How can I verify this?

  9. #8
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    If generated within a workspace, there would be a workspace.json file in the directory containing the application. With what version of Ext JS was the application originally written? Also, what version of Cmd are you using and is this different than the version used to create the application?

  10. #9
    Sencha User
    Join Date
    Sep 2009
    Location
    Colorado
    Posts
    11
    Answers
    1

    Default

    Gary, There IS a workspace.json file and it was created with an earlier version of 6 I believe.

  11. #10
    Sencha User
    Join Date
    Feb 2013
    Location
    California
    Posts
    11,985
    Answers
    506

    Default

    The workspaces.json file will tell you the most recent version of Ext JS. In .sencha/workspace/sencha.cfg it will tell you the Cmd version. If it were me, I would try grabbing the most recent (stable) version of Cmd and generate a new, separate workspace, using the desired version of Ext JS. Then I'd migrate the code into the new application. Since it was built with a trial version, hopefully it's not too large. The older the previous version of Ext JS was, the more minor issues there may be that need some attention.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 1 Feb 2016, 9:05 PM
  2. Error when Upgrading to 5, "Command must be run from a framework folder"
    By blomasky in forum Sencha Architect 3.x: Bugs
    Replies: 0
    Last Post: 8 Aug 2014, 8:58 AM
  3. How to install SenchaCmd Framework using Command Line on Mac
    By venkatesh.guttal in forum Sencha Cmd
    Replies: 1
    Last Post: 30 Aug 2013, 7:20 AM
  4. Sencha command packing .hg folder into apk
    By moakus in forum Sencha Cmd
    Replies: 1
    Last Post: 23 Jul 2013, 4:12 AM
  5. Folder sdk/command is necessary to package an application??
    By druidajes in forum Sencha Touch 2.x: Q&A
    Replies: 2
    Last Post: 27 Jun 2012, 8:19 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •