Results 1 to 7 of 7

Thread: Font awesome icons not showing on canvas

    Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-7618 in Architect 4.1.2.
  1. #1
    Sencha Premium User
    Join Date
    May 2016
    Posts
    13

    Default Font awesome icons not showing on canvas

    Hi,

    I opened a Sencha Architect project today after a long time of not using it (it is possible that I upgraded to the latest version of SA since opening this project) and none of the font awesome icons are showing.
    They are in the preview but not on the canvas.

    Can you let me know how to fix this?

    Thanks,

    Paul

  2. #2
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    Hello

    Can you post more info about your issue?
    - Which version of SA you have?
    - Which framework your project is using?
    - Which Theme are you using?

    When you check the library resources do you have font-awesome in the requires ?

    upload.png

    Can you post the example code how are using for your icons ? Perhaps some specific icons?

    Thank you
    Petr

  3. #3
    Sencha Premium User
    Join Date
    May 2016
    Posts
    13

    Default

    - Which version of SA you have?

    4.1.1.123


    - Which framework your project is using?

    ExtJS 6.2.x Classic


    - Which Theme are you using?

    Crisp Theme - this is slightly customised as it has a Scss resource.


    When you check the library resources do you have font-awesome in the requires ?

    Yes


    Can you post the example code how are using for your icons ? Perhaps some specific icons?

    In the config property editor for a button I have:
    iconCls: x-fa fa-pencil

  4. #4
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    Thanks for the report! I have opened a bug in our bug tracker.

  5. #5
    Sencha User
    Join Date
    Sep 2014
    Location
    Central Europe
    Posts
    795

    Default

    Quote Originally Posted by tRi11 View Post
    Can you let me know how to fix this?
    Pleas put the fontawesome-webfont.ttf file into the folder <projectFolder>\resources\font-awesome\fonts

    GET file:///C:/Users/Petr/Documents/ArchitectProjects/somethingWorkaround/resources/font-awesome/fonts/fontawesome-webfont.ttf

  6. #6
    Sencha Premium User
    Join Date
    May 2016
    Posts
    13

    Default

    Thanks, that fixed it

  7. #7
    Sencha Premium User dawesi's Avatar
    Join Date
    Mar 2007
    Location
    Melbourne, Australia (aka GMT+10)
    Posts
    1,242

    Default

    having same issue

    Sencha Architect

    Version: 4.2.4.389
    Channel: 4.2-stable
    Platform: 1.6.2.49 - win32 x64
    Renderer: 56.0.2924.87
    Cmd: 6.5.3.6
    Framework: Ext JS 6.5.x Classic
    Cloud Application Architect

    Sencha Specialist / Sencha MVP / Sencha Technical Trainer
    ExtJs Developer + Contributor since 0.2.2 - Champion of the per developer license.

Similar Threads

  1. Font Icons (Pictos, Font Awesome) not available on Windows 8.1
    By garysybex1 in forum Sencha Touch 2.x: Bugs
    Replies: 0
    Last Post: 1 Jun 2016, 5:33 AM
  2. Firefox 21.0 Font Awesome Icons Problem
    By thro in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 5 Apr 2016, 11:33 AM
  3. Using Font Awesome icons for tab 'glyphs'
    By jhoweaa in forum Ext JS 6.x Q&A
    Replies: 1
    Last Post: 26 Feb 2016, 2:16 PM
  4. Tree nodes with Font-Awesome icons
    By candycrate in forum Ext JS 6.x Q&A
    Replies: 5
    Last Post: 7 Sep 2015, 6:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •