Results 1 to 1 of 1

Thread: MinDateValidator error message

    Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1

    Default MinDateValidator error message

    Hi,
    We have 2 dates, from and to dates, we are using DateField. When using setMinValue(Date minValue) it creates MinDateValidator. The problem is the format on this validator, when manually entering the date, the validator shows the following message:"The date in this field must be {date} or later" (the date is in the format mm/dd/yyyy), but my DateField is in the format "dd/mm/yyyy".
    I noticed that MaxDateValidator has a constructor that receives a format, but MinDateValidator doesn't. But even having that in the constructor will not help, because setMinValue method ignores the field's format.

    I have attached 2 screen shots just in case.

    Can you please fix it so when creating the validators the field's format will be passed to the validator.

    Thank you,
    Alon
    Attached Images Attached Images

Similar Threads

  1. Replies: 4
    Last Post: 9 Aug 2010, 11:32 AM
  2. Replies: 5
    Last Post: 21 Jun 2009, 10:32 PM
  3. BasicForm with xml error reader: default error message displayed
    By michele.segata in forum Ext 2.x: Help & Discussion
    Replies: 4
    Last Post: 10 Jan 2009, 6:27 AM
  4. How to display an error message in case of Combox load error?
    By memph in forum Ext 1.x: Help & Discussion
    Replies: 1
    Last Post: 27 Jul 2007, 8:39 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •